summaryrefslogtreecommitdiff
path: root/dev-ruby/org-ruby/org-ruby-0.9.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/org-ruby/org-ruby-0.9.12.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/org-ruby/org-ruby-0.9.12.ebuild')
-rw-r--r--dev-ruby/org-ruby/org-ruby-0.9.12.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/org-ruby/org-ruby-0.9.12.ebuild b/dev-ruby/org-ruby/org-ruby-0.9.12.ebuild
new file mode 100644
index 000000000000..f21926e07642
--- /dev/null
+++ b/dev-ruby/org-ruby/org-ruby-0.9.12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="README.org History.org"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby routines for parsing org-mode files"
+HOMEPAGE="https://github.com/wallyqs/org-ruby"
+SRC_URI="https://github.com/wallyqs/${PN}/archive/version-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_S="${PN}-version-${PV}"
+
+ruby_add_rdepend "=dev-ruby/rubypants-0.2*:0"
+ruby_add_bdepend "test? ( dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ #Fix tests until rspec:3 is available in the tree
+ sed -i -e "s/truthy/true/" -e "s/falsy/false/" spec/headline_spec.rb spec/parser_spec.rb spec/line_spec.rb || die
+}