summaryrefslogtreecommitdiff
path: root/dev-ruby/org-ruby/org-ruby-0.9.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/org-ruby/org-ruby-0.9.12.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/org-ruby/org-ruby-0.9.12.ebuild')
-rw-r--r--dev-ruby/org-ruby/org-ruby-0.9.12.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/org-ruby/org-ruby-0.9.12.ebuild b/dev-ruby/org-ruby/org-ruby-0.9.12.ebuild
new file mode 100644
index 000000000000..ab67c4933d9f
--- /dev/null
+++ b/dev-ruby/org-ruby/org-ruby-0.9.12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="README.org History.org"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby routines for parsing org-mode files"
+HOMEPAGE="https://github.com/wallyqs/org-ruby"
+SRC_URI="https://github.com/wallyqs/${PN}/archive/version-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_S="${PN}-version-${PV}"
+
+ruby_add_rdepend ">=dev-ruby/rubypants-0.2:0"
+ruby_add_bdepend "test? ( dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ #Fix tests until rspec:3 is available in the tree
+ sed -i -e "s/truthy/true/" -e "s/falsy/false/" spec/headline_spec.rb spec/parser_spec.rb spec/line_spec.rb || die
+}