summaryrefslogtreecommitdiff
path: root/dev-ruby/ostruct
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-07 04:26:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-07 04:26:50 +0100
commit7ad61ca2bfc8f8da08d2fb3085e4333dcccb0a64 (patch)
treef7c41a49b46acf8ae70e84a70c452a7d121c5458 /dev-ruby/ostruct
parentd6106fb0c1ab8f79024ab6a9ac2062ddc85d4e07 (diff)
gentoo auto-resync : 07:10:2024 - 04:26:50
Diffstat (limited to 'dev-ruby/ostruct')
-rw-r--r--dev-ruby/ostruct/Manifest3
-rw-r--r--dev-ruby/ostruct/metadata.xml11
-rw-r--r--dev-ruby/ostruct/ostruct-0.6.0.ebuild28
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/ostruct/Manifest b/dev-ruby/ostruct/Manifest
new file mode 100644
index 000000000000..a30dd1112a3a
--- /dev/null
+++ b/dev-ruby/ostruct/Manifest
@@ -0,0 +1,3 @@
+DIST ostruct-0.6.0.tar.gz 10757 BLAKE2B 68742978efc348d28361716a18a4b9a5e23270e37a104aa3e620d3a751182f22003db467c2424025c831315a2ddb7bf4f9bb4f76b43ab612f64eb56875b55860 SHA512 34afddbc0e881432fcd143669ad182d3ddef7b2245d1429466ff893f8a419482b3fc577eea331d3edfecbe2ac831e9b3b1e5d0baa66de5528fe312afb4e2b087
+EBUILD ostruct-0.6.0.ebuild 864 BLAKE2B 0390aa920bbcede9ab52f5034f88906e402990594df271e99219e2248eb8748799e67abb8338028defe76b05ed15a7ce0af7a6a854db0ab4b2100ea4da9d2499 SHA512 ec86c50e7302e2502a16992b1b267ca2e8af2de13ff4c9fa8f12dd98b988629e6998093462b643583609177964bcea5a596c06bcc5732cfa1c9bf5c0ec402c5a
+MISC metadata.xml 339 BLAKE2B 6573df2eaa31c356454c12307d631be72f0d9707484c2a8e1afe20299a898d1051a43ab247d741b7e823a00b40a45f0a3e37db1c1de517d2244a31bd37bd4f9d SHA512 fb012b1191bd6a69907246e11a0e787d6e6e85e1b82a059650086c0ea97877ba1632ab888b9d1a09c9c2ef9578e0808648868ada5f8a2e31df5f233673a402d7
diff --git a/dev-ruby/ostruct/metadata.xml b/dev-ruby/ostruct/metadata.xml
new file mode 100644
index 000000000000..206b75ea5ef2
--- /dev/null
+++ b/dev-ruby/ostruct/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/ostruct</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ostruct/ostruct-0.6.0.ebuild b/dev-ruby/ostruct/ostruct-0.6.0.ebuild
new file mode 100644
index 000000000000..2f08ed1e2061
--- /dev/null
+++ b/dev-ruby/ostruct/ostruct-0.6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="ostruct.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Class to build custom data structures, similar to a Hash"
+HOMEPAGE="https://github.com/ruby/ostruct"
+SRC_URI="https://github.com/ruby/ostruct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+ruby_add_depend "test? ( dev-ruby/test-unit dev-ruby/test-unit-ruby-core )"
+
+all_ruby_prepare() {
+ sed -e 's/__FILE__/"ostruct.gemspec"/' \
+ -e 's/__dir__/"."/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}