summaryrefslogtreecommitdiff
path: root/dev-ruby/pairing_heap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-27 19:39:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-27 19:39:54 +0000
commit249ae8c1a241b514fc83737660927ee175091346 (patch)
treea2a02c05fda158e709612d8ca505847b441412db /dev-ruby/pairing_heap
parent99995c94c01b6d74165c7ee31be36275846b14b8 (diff)
gentoo auto-resync : 27:12:2023 - 19:39:54
Diffstat (limited to 'dev-ruby/pairing_heap')
-rw-r--r--dev-ruby/pairing_heap/Manifest1
-rw-r--r--dev-ruby/pairing_heap/pairing_heap-3.0.1.ebuild31
2 files changed, 0 insertions, 32 deletions
diff --git a/dev-ruby/pairing_heap/Manifest b/dev-ruby/pairing_heap/Manifest
index 6fe0853c7726..c11d5f74d0ff 100644
--- a/dev-ruby/pairing_heap/Manifest
+++ b/dev-ruby/pairing_heap/Manifest
@@ -1,4 +1,3 @@
DIST pairing_heap-3.0.1.tar.gz 16965 BLAKE2B 80200dd98676c8ee9258ef96d296a4169b56d104875368bb8401b0f7d53494e3bbff8cfc5a536bdb24d844893ebe6962af709614b399c8c56980ee578ec2740b SHA512 0d22ccd42275aec54ff6960094c7ef14ad487835ba23217882a649c66585fc6c21af8a2f27f7a0a410fba6daf157ffdae6b74f1fdd798903ac597851945dee41
EBUILD pairing_heap-3.0.1-r1.ebuild 914 BLAKE2B 29618ede7fc91f2d6d3ca9a1f74c5f2034a500b1e7d06b33d416e5d4d9fbc6a7f9629611be35449e862ad91fe88a163d8617bc1a9369d1ce1685c86c26167370 SHA512 10ab7611f439391d98a0fea013b713d593df40a7972a25988949867b33e1fcbeccb63a3aaa8dea8a1fc2681d14be3c537960f3e5f884c3dc7c2a8bd0e3b24b83
-EBUILD pairing_heap-3.0.1.ebuild 811 BLAKE2B 168d36e10ebc5497f5e35b9689126a5533c23e096ad24d9862696cab17ea9c35bf1b67c0ced55f897ce7e56cefaf88825f221a853acafcafa9f1d022420ae182 SHA512 cece03ffeba711f1163b591843a1d2d5fd409414c283dcdd707e00855fe676dada29e00b748a0af49d383f5303d2686c8fab5eca20a17d33ef935956a5c170a9
MISC metadata.xml 497 BLAKE2B 031d1ac42034e382202b0654788c13e078be09c082b5d1fe7099fcb5f93a0e53362f50180f73ee212e6b37d840968b3b2165c6270531b3cdde10b662f8574159 SHA512 cf96df8957624b2ba909ed222343e1fd74dafce6618fc4f7914afd841e2e425afd4609d841a4f876cdb24711187dbb8ebb12bd404a049833edcc7ad7eb6cb5e5
diff --git a/dev-ruby/pairing_heap/pairing_heap-3.0.1.ebuild b/dev-ruby/pairing_heap/pairing_heap-3.0.1.ebuild
deleted file mode 100644
index 7f77523824d5..000000000000
--- a/dev-ruby/pairing_heap/pairing_heap-3.0.1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby30 ruby31 ruby32"
-
-RUBY_FAKEGEM_BINWRAP=""
-RUBY_FAKEGEM_EXTRADOC="README.md"
-RUBY_FAKEGEM_GEMSPEC="pairing_heap.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Performant priority queue with support for changing priority"
-HOMEPAGE="https://github.com/mhib/pairing_heap"
-SRC_URI="https://github.com/mhib/pairing_heap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/minitest )"
-
-all_ruby_prepare() {
- sed -i -e '/require.*\(bundler\|standard\)/ s:^:#:' Rakefile || die
-
- sed -e 's:_relative ": "./:' \
- -e 's/__dir__/"."/' \
- -e 's/git ls-files -z/find * -print0/' \
- -i ${RUBY_FAKEGEM_GEMSPEC} || die
-}