summaryrefslogtreecommitdiff
path: root/dev-ruby/parallel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /dev-ruby/parallel
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'dev-ruby/parallel')
-rw-r--r--dev-ruby/parallel/Manifest2
-rw-r--r--dev-ruby/parallel/parallel-1.12.0.ebuild54
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-ruby/parallel/Manifest b/dev-ruby/parallel/Manifest
index 1ee808b769ca..53f4bbf594d2 100644
--- a/dev-ruby/parallel/Manifest
+++ b/dev-ruby/parallel/Manifest
@@ -1,5 +1,3 @@
-DIST parallel-1.12.0.tar.gz 20472 BLAKE2B b6e998588f94e07194c19d4bf38964aa5e846b7f62c7a267041473a237a9d8fdebb4dc501695b00902c852021ce7817b24bfe01dcf4c0e18445b46d46c7cb42b SHA512 8ca41cf577ee4743ef50abe693d0040eaab12b61eca17c3d6c33d3720c38563e2df9a0eb5af0fe9d8c34c3b910f1c626ce141fd2eb7d2edfbe5abbcb9f54191b
DIST parallel-1.12.1.tar.gz 20499 BLAKE2B f0fa25b9fe65e44804854f703dd2d80e53572e64c2072c418d0462922bd04f89cff0e023caf4293d8a1504ad66a2a29ebbdd01920fc6fe400837859da0f0eb78 SHA512 f0ab332dfa60bb3190bba8275dbdf7b54d3de205ab76099d11f0a64e1fc28e1ba7e72d1a242bd615015c2d09a3f08df01c382869fd6990b854b01fe182245857
-EBUILD parallel-1.12.0.ebuild 1703 BLAKE2B ba3bce20cf9bf46583d7f86a96672e7634d2b41db785589b8048dd56452ff6b3f1b215638a3d189d677b9e597278ca5462b907179650ec49005f5d5345b16ac4 SHA512 da3a7ed5449817d475ab381949bf8e55d32abe4b319a0000960c3cdc38b5c62f909dc40c9a8ff8b18b75072429fb9da1c48754779c565f13aaafafac9ce9179d
EBUILD parallel-1.12.1.ebuild 1704 BLAKE2B 8b686ca1ce60df0b706f20e425b27693b8c1b93b0065bcbc4eb580e0527f35d9b6a9ce981d4ecf3a8a9f1c23e1200b5758ee9a817f66529780b8cc7b15615677 SHA512 c8496b23a1c7a6945d82eaf9e85cec0f36bf95c8e9d4b7f1178dae58f24e9d8046288b11cc9182fb8331a0caaa5fa812dfd91be5c907dbf3d4af507bcf168e01
MISC metadata.xml 342 BLAKE2B 0860273d70423cb92207369335e1f684ea623e1217d7aaf4d016d9aff9c02b0b8dc9af3654b523f77cbd8d92f7043887a97ff87abb79d3c65b66b0e6b40082fb SHA512 805eaecfea071b1d632ade7da42ed63717d2f829c4c99e29a4600b26a81e87c4032d7ee441b865d86f37faa13f455c9f2888dc8099178cf6211ae13d3e3e1835
diff --git a/dev-ruby/parallel/parallel-1.12.0.ebuild b/dev-ruby/parallel/parallel-1.12.0.ebuild
deleted file mode 100644
index ae6e3c6512aa..000000000000
--- a/dev-ruby/parallel/parallel-1.12.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="Readme.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Run any code in parallel Processes or Threads"
-HOMEPAGE="https://github.com/grosser/parallel"
-LICENSE="MIT"
-SRC_URI="https://github.com/grosser/parallel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64"
-SLOT="1"
-IUSE="test"
-
-DEPEND+="test? ( sys-process/lsof )"
-
-ruby_add_bdepend "
- test? ( dev-ruby/ruby-progressbar dev-ruby/activerecord:4.2 dev-ruby/sqlite3 )"
-
-each_ruby_prepare() {
- # Make sure the correct ruby is used for testing
- sed -e 's:ruby :'${RUBY}' :' -i spec/parallel_spec.rb || die
-}
-
-all_ruby_prepare() {
- sed -i -e '/bundler/ s:^:#:' \
- -e '1i require "tempfile"; gem "activerecord", "~>4.2.0"' spec/cases/helper.rb || die
- sed -i -e '3irequire "timeout"' spec/spec_helper.rb || die
-
- # Avoid a failing spec regarding to pipes. The spec seems like it
- # should always fail.
- sed -e '/does not open unnecessary pipes/,/end/ s:^:#:' \
- -i spec/parallel_spec.rb || die
-
- # Avoid fragile ar sqlite tests. They throw ReadOnly errors every now and then.
- sed -i -e '/works with SQLite in/,/end/ s:^:#:' spec/parallel_spec.rb || die
-
- # Avoid spec broken on Ruby 2.1 that clearly doesn't match code and doesn't really test anything
- sed -i -e '/doesnt use Etc.nprocessors in Ruby 2.1 and below/,/end/ s:^:#:' spec/parallel_spec.rb || die
-}
-
-each_ruby_test() {
- # Set RUBYLIB explicitly for the ruby's that get started from the specs.
- TRAVIS=true RUBYLIB="lib" ${RUBY} -S rspec-3 spec || die
-}