summaryrefslogtreecommitdiff
path: root/dev-ruby/pg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-ruby/pg
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-ruby/pg')
-rw-r--r--dev-ruby/pg/Manifest3
-rw-r--r--dev-ruby/pg/files/postgresql10-tests.patch49
-rw-r--r--dev-ruby/pg/pg-0.21.0.ebuild57
3 files changed, 0 insertions, 109 deletions
diff --git a/dev-ruby/pg/Manifest b/dev-ruby/pg/Manifest
index 18c86e1e8c19..f0238f67c7d2 100644
--- a/dev-ruby/pg/Manifest
+++ b/dev-ruby/pg/Manifest
@@ -1,6 +1,3 @@
-AUX postgresql10-tests.patch 1747 BLAKE2B e0a992461221f31cca1f39453e077a1d04d3f436e0eba3b683ed42092d266a8edb8a46e61933ac41e94ead483bac325833f1c21bfc57cf7ebb160f046d80e1f6 SHA512 89a7937b0791307366fbc97549d48cb7bdf92b66895b1de7dd554a040ad6a08b4af69709bf1318df95cdaf9824415d76b5f6be98be48995b75909fbfeefb6295
-DIST pg-0.21.0.gem 214016 BLAKE2B 9e27646cd85bc97dedfb980f4851b19a1ef2aad17f6a5c60726c1683642af5c4cf87d518b300fb4c894e1580f808f8af6158b57f1ac25971c1fc55818abee6f4 SHA512 590a8c34487d2cf030082cfff87b2cc83b636df06a931e394acfb098ecb5728e793d777f125b036ee9953bbd21ec5facf91c932930acccb507d3394f2fc4cc5b
DIST pg-1.2.2.gem 196608 BLAKE2B 068be98d190cb4074cc89bdb5b376322f323950909f7a6fddc8669a3ff0f85eef9f512bd2ec7121707e9ea077b2b428f698e84f2118c76e34f5def75ca303fca SHA512 5c7cc90afb75a66e80cfc34c4875cf22b005aa0a27e78db6f71d1829f870c6409b73326a9925f79c0d642e93ea51d1f84c7383323fea44b7488e83deb7754951
-EBUILD pg-0.21.0.ebuild 1668 BLAKE2B f0ee08a6207cb8e9ceb5dbc2cfb70030fab6e5b9fd1b293b99f401807fc55759e76411a2d30e0f5966b9d24c56a05e3e5db66861f90d1db08993828afc47dad6 SHA512 bd5a27376d319aee0cdd7e49ce46fff883f26769b11bd58f14cda9211c3e6915c31becce8fcd38d33f3f27027228a68b1bea6c48b66feb69dbd2c1291fe2ad94
EBUILD pg-1.2.2.ebuild 1595 BLAKE2B f3dcdc64b69e3e8da9a9981ff97c72ebf9f58044e43be2283cceb70e45a70f349970f003d12ec469827170192c441044e92547e9ae0bd8959fc9cd34fc6d1aa1 SHA512 b90c98ddd7ee4de299f7bfad52955e76a54cd615218c8e86ed1cb20e98731cdbee20e0f8cc3b8faa125969233f3b974803f38085feece6c0cd125cf04261835d
MISC metadata.xml 337 BLAKE2B 1ecaa6a65230c424031ecd8a3e462240e10caedc1107b6818bf866cd0c698a5f534d450a467031755d80a242a84e55a5e29a48a480c1b55387597765ae0f4b1f SHA512 9e38510b1ad726a3867df6b39f26f887f65dda5e60a46f0f867c65d5759a534c7adb6ffd072882437cd3a6f7fc1ebdf91c79def51a93f4360427e6f14aa3455a
diff --git a/dev-ruby/pg/files/postgresql10-tests.patch b/dev-ruby/pg/files/postgresql10-tests.patch
deleted file mode 100644
index f9b7c1579a91..000000000000
--- a/dev-ruby/pg/files/postgresql10-tests.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-# HG changeset patch
-# User Lars Kanis <kanis@comcard.de>
-# Date 1508756565 -7200
-# Node ID fe63160e8a9803e257231d879fab2841ba44c37a
-# Parent d6d5533dfca85b618232fe3e9e56e59dbee99de6
-Adjust tests for PostgreSQL-10
-
-diff --git a/spec/helpers.rb b/spec/helpers.rb
---- a/spec/helpers.rb
-+++ b/spec/helpers.rb
-@@ -251,7 +251,7 @@
-
- def check_for_lingering_connections( conn )
- conn.exec( "SELECT * FROM pg_stat_activity" ) do |res|
-- conns = res.find_all {|row| row['pid'].to_i != conn.backend_pid }
-+ conns = res.find_all {|row| row['pid'].to_i != conn.backend_pid && ["client backend", nil].include?(row["backend_type"]) }
- unless conns.empty?
- puts "Lingering connections remain:"
- conns.each do |row|
-diff --git a/spec/pg/connection_spec.rb b/spec/pg/connection_spec.rb
---- a/spec/pg/connection_spec.rb
-+++ b/spec/pg/connection_spec.rb
-@@ -232,7 +232,7 @@
- described_class.connect(@conninfo).finish
- sleep 0.5
- res = @conn.exec(%[SELECT COUNT(*) AS n FROM pg_stat_activity
-- WHERE usename IS NOT NULL])
-+ WHERE usename IS NOT NULL AND application_name != ''])
- # there's still the global @conn, but should be no more
- expect( res[0]['n'] ).to eq( '1' )
- end
-@@ -1537,9 +1537,14 @@
- end
-
- it "shouldn't type map params unless requested" do
-- expect{
-- @conn.exec_params( "SELECT $1", [5] )
-- }.to raise_error(PG::IndeterminateDatatype)
-+ if @conn.server_version < 100000
-+ expect{
-+ @conn.exec_params( "SELECT $1", [5] )
-+ }.to raise_error(PG::IndeterminateDatatype)
-+ else
-+ # PostgreSQL-10 maps to TEXT type (OID 25)
-+ expect( @conn.exec_params( "SELECT $1", [5] ).ftype(0)).to eq(25)
-+ end
- end
-
- it "should raise an error on invalid encoder to put_copy_data" do
diff --git a/dev-ruby/pg/pg-0.21.0.ebuild b/dev-ruby/pg/pg-0.21.0.ebuild
deleted file mode 100644
index 99553f10c3f5..000000000000
--- a/dev-ruby/pg/pg-0.21.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="ChangeLog Contributors.rdoc README.rdoc History.rdoc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
-HOMEPAGE="https://github.com/ged/ruby-pg"
-
-LICENSE="|| ( GPL-2 Ruby )"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND+=" dev-db/postgresql:*"
-DEPEND+=" dev-db/postgresql
- test? ( >=dev-db/postgresql-9.4[server,threads] )"
-
-PATCHES=( "${FILESDIR}/postgresql10-tests.patch" )
-
-all_ruby_prepare() {
- # hack the Rakefile to make it sure that it doesn't load
- # rake-compiler (so that we don't have to depend on it and it
- # actually works when building with USE=doc).
- sed -i \
- -e '/Rakefile.cross/s:^:#:' \
- -e '/ExtensionTask/,/^end$/ s:^:#:' \
- Rakefile || die
-}
-
-each_ruby_configure() {
- ${RUBY} -C ext extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake V=1 -C ext CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
- cp ext/*$(get_libname) lib || die
-}
-
-each_ruby_test() {
- if [[ "${EUID}" -ne "0" ]]; then
- # Make the rspec call explicit, this way we don't have to depend
- # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
- # the whole extension from scratch.
- RSPEC_VERSION=3 ruby-ng_rspec
- else
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
-}