summaryrefslogtreecommitdiff
path: root/dev-ruby/plist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/plist
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/plist')
-rw-r--r--dev-ruby/plist/Manifest3
-rw-r--r--dev-ruby/plist/metadata.xml11
-rw-r--r--dev-ruby/plist/plist-3.4.0.ebuild28
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/plist/Manifest b/dev-ruby/plist/Manifest
new file mode 100644
index 000000000000..928486432e1d
--- /dev/null
+++ b/dev-ruby/plist/Manifest
@@ -0,0 +1,3 @@
+DIST plist-3.4.0.tar.gz 36637 BLAKE2B 8ea6b11c9adca311d91cf22f7ca11cdcb3acbbb97e18a813de754acc4474183fdd7cdb569b8fe64da06170219ef2fdcabec1d2349399006254c7f399365d1f97 SHA512 01dc47b183b7dce1f20fad8d68d1bebbb6d509c62b77f41855305bf5aafd1abf7960d74f1cb9d2467648a166fbb1747bbdd57f228f10ac091d16ab1a7189525b
+EBUILD plist-3.4.0.ebuild 791 BLAKE2B adb31d25b4b406ad92a9f1ecd2d2854ef8a5555b6561e1fef1540497c7bedb2301a9911e9e8b75e606010b5615de6a6d366706b6ae4c529a85031d236ecadf13 SHA512 ebeae751053b71bedc238620525ac5557b792935690d6281c36d6f249db9ae0160e4d04972837d77a590df8483a1d52530d454d95a771c7230473f2a8b5546cd
+MISC metadata.xml 330 BLAKE2B 0be0bc0db0a0b4ac8ce4b11ef9c0b67b13238e4336280a2bdeee8317f58e4a97a78fa63b75cf1aa01b00d0c69bf3b53950f68c22a04dcac35b63097041ccdb7a SHA512 9b26476dd91dbe33c4ceeac8a49208718f177262c94d272b8c79cb49806892d21a815cfd379ce38182d00c9e542df2ca1131d6bec4523d694f5582a80c52d337
diff --git a/dev-ruby/plist/metadata.xml b/dev-ruby/plist/metadata.xml
new file mode 100644
index 000000000000..d2a2918c128c
--- /dev/null
+++ b/dev-ruby/plist/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">patsplat/plist</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/plist/plist-3.4.0.ebuild b/dev-ruby/plist/plist-3.4.0.ebuild
new file mode 100644
index 000000000000..b7acbddff13f
--- /dev/null
+++ b/dev-ruby/plist/plist-3.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library to manipulate Property List files, also known as plists"
+HOMEPAGE="https://github.com/patsplat/plist"
+SRC_URI="https://github.com/patsplat/plist/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+ sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}