summaryrefslogtreecommitdiff
path: root/dev-ruby/pp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-19 00:30:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-19 00:30:04 +0000
commit781c9128468d2e8302221d4d7152ae09cffc4a9e (patch)
tree1f0892c391dbb3e56d61a206fdc800034917eead /dev-ruby/pp
parentcade0827f4ab3a7b13c870b7841c4462dde54dc6 (diff)
gentoo auto-resync : 19:03:2025 - 00:30:03
Diffstat (limited to 'dev-ruby/pp')
-rw-r--r--dev-ruby/pp/Manifest3
-rw-r--r--dev-ruby/pp/metadata.xml12
-rw-r--r--dev-ruby/pp/pp-0.6.2.ebuild26
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/pp/Manifest b/dev-ruby/pp/Manifest
new file mode 100644
index 000000000000..d33cc04ca41d
--- /dev/null
+++ b/dev-ruby/pp/Manifest
@@ -0,0 +1,3 @@
+DIST pp-0.6.2.tar.gz 12063 BLAKE2B 7e76e95f8fe5873c9989037bcaf2df228561ec76c38215db2e5e243fbb058359fff000b1b0f1565e3cb1cc1e4a7a17f8b9d3838d0126495e94a34d67b4591621 SHA512 37657cc53f0522dde19c8be52c8eea805e8ba8b651d233e3c1096dbd6c8722f22d012548f0972ae95c915cb64b4bf2a51ba3bae5fdc5f1b5632b6cbf1774fc5c
+EBUILD pp-0.6.2.ebuild 792 BLAKE2B c6ebd31dca7bb9128cde644d8db95fd83e6ce82b2219cb9a9a7d2522fd8a2d32fc96301d982001433e204db9a5a7c55b6c1ef0d8519e055f8d858548f8ba4659 SHA512 6513d85d15bf6722f1e99fff03f600c6233fcb749bc79830385350196207413b63b998d0a7a0c576cc7c166127005c19893d9eb67d24f749e350370869db7451
+MISC metadata.xml 380 BLAKE2B 05d70a7bc6a69c3cceb7d0f079032f6b809bec6d3f248a1f8e7c1d66a99942ed5b7628b29ac4e5df50e531753a4735197126edf9bd8fd1324c453b7d5bfa3b1d SHA512 78f3b233f4adb623605ca814452a26bbccaa2d90ba01a64e9c39f57cd097f5f751a45166e63ea70eaabf05e6826fe0d0fa73c39da424d15e417db38b314e8bf7
diff --git a/dev-ruby/pp/metadata.xml b/dev-ruby/pp/metadata.xml
new file mode 100644
index 000000000000..e072441d3b5e
--- /dev/null
+++ b/dev-ruby/pp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/pp</remote-id>
+ <remote-id type="rubygems">pp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/pp/pp-0.6.2.ebuild b/dev-ruby/pp/pp-0.6.2.ebuild
new file mode 100644
index 000000000000..d02dac173df9
--- /dev/null
+++ b/dev-ruby/pp/pp-0.6.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33 ruby34"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="pp.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a PrettyPrinter for Ruby objects"
+HOMEPAGE="https://github.com/ruby/pp"
+SRC_URI="https://github.com/ruby/pp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}