summaryrefslogtreecommitdiff
path: root/dev-ruby/psych/psych-5.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-22 12:52:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-22 12:52:10 +0000
commit736633fa866abdd7c155cabb02adf278c5237640 (patch)
tree847aff3277bceae8b34d29ff6c16cac3ad4b288e /dev-ruby/psych/psych-5.0.2.ebuild
parentf926b97bb4ca0ec30c10ee9075bd3fd3b1df2be7 (diff)
gentoo auto-resync : 22:01:2023 - 12:52:10
Diffstat (limited to 'dev-ruby/psych/psych-5.0.2.ebuild')
-rw-r--r--dev-ruby/psych/psych-5.0.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/psych/psych-5.0.2.ebuild b/dev-ruby/psych/psych-5.0.2.ebuild
new file mode 100644
index 000000000000..4f5a5a2581c2
--- /dev/null
+++ b/dev-ruby/psych/psych-5.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/psych/extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A YAML parser and emitter"
+HOMEPAGE="https://github.com/ruby/psych"
+
+LICENSE="BSD-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="$(ver_cut 1)"
+IUSE="test"
+
+RDEPEND+=" >=dev-libs/libyaml-0.2.5"
+BDEPEND+=" >=dev-libs/libyaml-0.2.5"
+
+ruby_add_rdepend "dev-ruby/stringio"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}