summaryrefslogtreecommitdiff
path: root/dev-ruby/rails/rails-4.2.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/rails/rails-4.2.10.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/rails/rails-4.2.10.ebuild')
-rw-r--r--dev-ruby/rails/rails-4.2.10.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/rails/rails-4.2.10.ebuild b/dev-ruby/rails/rails-4.2.10.ebuild
new file mode 100644
index 000000000000..353465f24e79
--- /dev/null
+++ b/dev-ruby/rails/rails-4.2.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+# The guides are now here but we'd need to rebuilt them first.
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md guides/CHANGELOG.md"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux"
+
+IUSE="+asset-pipeline"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/actionview-${PV}
+ ~dev-ruby/activejob-${PV}
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/railties-${PV}
+ >=dev-ruby/bundler-1.3 =dev-ruby/bundler-1*
+ dev-ruby/sprockets-rails:*
+ asset-pipeline? (
+ dev-ruby/jquery-rails:*
+ >=dev-ruby/sass-rails-5.0:5.0
+ >=dev-ruby/uglifier-1.3.0:*
+ >=dev-ruby/coffee-rails-4.1.0:*
+ )"
+
+# also: turbolinks, >=jbuilder-1.2:1