summaryrefslogtreecommitdiff
path: root/dev-ruby/rb-inotify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-06 12:54:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-06 12:54:39 +0000
commit56330f065f2b903d9e1b2dffc63719fef5897a45 (patch)
tree659a7ebca7cb9f7504b018c1484df84ba4f9ab01 /dev-ruby/rb-inotify
parent1774f0a748546cbd792bf1eb44757b63be2e0114 (diff)
gentoo auto-resync : 06:01:2024 - 12:54:38
Diffstat (limited to 'dev-ruby/rb-inotify')
-rw-r--r--dev-ruby/rb-inotify/Manifest1
-rw-r--r--dev-ruby/rb-inotify/rb-inotify-0.10.1-r1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/rb-inotify/Manifest b/dev-ruby/rb-inotify/Manifest
index 4f1caa570c7b..a6def31172af 100644
--- a/dev-ruby/rb-inotify/Manifest
+++ b/dev-ruby/rb-inotify/Manifest
@@ -1,3 +1,4 @@
DIST rb-inotify-0.10.1.gem 15872 BLAKE2B 1ddf4fe8de7cdd348e007ac29ab7b41667092439f9b70eeae49d7e917351c73512e43a7ccf6679af1c9225b19efadb6a1581f63e1958d2a31d61f2bce5a13664 SHA512 7831a6228f2d6363e634b8d6b4a12206f19b96098e5dfba1d27b1e994a7284a5cb58cd0299d861a6ff275fc8248c0e68faaaf786d6222ad68f3e6b43ccea29ec
+EBUILD rb-inotify-0.10.1-r1.ebuild 973 BLAKE2B 2e324b25d7f6316ee8ead72a219e67505632bd69fdcf63ba0ebff427e1d2d8ec8a73bc3d0333300567d38dfa1a0abae70d7444c48236dd6d7da2ff59d866cdb7 SHA512 e504cfc7a25f4677b0f30d4bb9851293a377ccdeeef644bd710b5a1fde222976639d252218cf12015b19cacd025a6b3251f0e2c8f90a27ff23f9847f2f805837
EBUILD rb-inotify-0.10.1.ebuild 973 BLAKE2B 747ae580b2acc635080f830ed3f0700efeefb1fafcb519200279615316bdb1d2ad651b1b48234d91deacdb5de3849342afb81eb2a39bb880d601089ad63481ad SHA512 ce95db7f3a54f58d4cd588aaceb8d88e695ca9c102aee88db94dc3629810af2fb19d732596b7107660e271d245f58b162b83ce6cdc24ca2835deafa501c9c219
MISC metadata.xml 342 BLAKE2B 6f4587e7af70218aed1523368746721fd9fc5431a52adf87f2ecd31fcd3027564744087e40b0e3ae5282e2b7391b2e0bbf95121b691730796a2470c276d0fffe SHA512 c9ed5a3b063886bba917410aaf1bf45b5da718c29299197369e29e4c5a567df3ef5791f934dd265b9904a557a4a9761d8df5ac5f817eedae74e7577ccf88b5ee
diff --git a/dev-ruby/rb-inotify/rb-inotify-0.10.1-r1.ebuild b/dev-ruby/rb-inotify/rb-inotify-0.10.1-r1.ebuild
new file mode 100644
index 000000000000..823ea839dedd
--- /dev/null
+++ b/dev-ruby/rb-inotify/rb-inotify-0.10.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thorough inotify wrapper for Ruby using FFI"
+HOMEPAGE="https://github.com/nex3/rb-inotify"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/ffi"
+
+ruby_add_bdepend "test? ( dev-ruby/concurrent-ruby )"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on jeweler.
+ sed -i -e '/:build/ s:^:#:' -e '/module Jeweler/,/^end/ s:^:#:' -e '/class Jeweler/,/^end/ s:^:#:' Rakefile || die
+
+ # Remove mandatory markup processor from yard options, bug 436112.
+ sed -i -e '/maruku/d' .yardopts || die
+
+ sed -i -e '/bundler/ s:^:#:' -e '1irequire "pathname"' spec/spec_helper.rb || die
+}