summaryrefslogtreecommitdiff
path: root/dev-ruby/rchardet/rchardet-1.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-ruby/rchardet/rchardet-1.8.0.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-ruby/rchardet/rchardet-1.8.0.ebuild')
-rw-r--r--dev-ruby/rchardet/rchardet-1.8.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/rchardet/rchardet-1.8.0.ebuild b/dev-ruby/rchardet/rchardet-1.8.0.ebuild
new file mode 100644
index 000000000000..519a59d0d6ae
--- /dev/null
+++ b/dev-ruby/rchardet/rchardet-1.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_GEMSPEC="rchardet.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Character encoding auto-detection in Ruby"
+HOMEPAGE="https://github.com/jmhodges/rchardet"
+SRC_URI="https://github.com/jmhodges/rchardet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' -e '/minitest\/rg/ s:^:#:' test/test_helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}