summaryrefslogtreecommitdiff
path: root/dev-ruby/rdiscount
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-07 12:53:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-07 12:53:51 +0000
commit02814fd00146251691678aa18d9937665c677086 (patch)
tree5408cf868c128b241de5bab0f807058065bea7c8 /dev-ruby/rdiscount
parent79713e75fcc5c5cb55d1b1beac008683b57c8805 (diff)
gentoo auto-resync : 07:01:2024 - 12:53:51
Diffstat (limited to 'dev-ruby/rdiscount')
-rw-r--r--dev-ruby/rdiscount/Manifest4
-rw-r--r--dev-ruby/rdiscount/metadata.xml3
-rw-r--r--dev-ruby/rdiscount/rdiscount-2.2.7.3.ebuild43
3 files changed, 48 insertions, 2 deletions
diff --git a/dev-ruby/rdiscount/Manifest b/dev-ruby/rdiscount/Manifest
index 12285d4b52d5..ac61e023de9f 100644
--- a/dev-ruby/rdiscount/Manifest
+++ b/dev-ruby/rdiscount/Manifest
@@ -1,3 +1,5 @@
DIST rdiscount-2.2.7.1.gem 74240 BLAKE2B 06779a601c8d13b90f5d9fb1c38712431671eab1cb2ef012dee284ddb6da254a0c788f16295438913d68f3641db2ec48c7cea3bade4f36fdc55b7a6049119fd4 SHA512 e67bbbb7f19ef14a729642e2059f0920b65a3f254507204955ab6d34529ade643ee7adecc3db2c61ca5462d266f88ea336bd228401e3cd0fad98e2e7763dd8d3
+DIST rdiscount-2.2.7.3.gem 75776 BLAKE2B 6dc3110d0acf1adf86450e520e43e9d6602ca8980e85d5d0122f2e49026e6b6a32eca72a44631fa1fa03e6c649b21941a820cb07a1d8cc30d3bde3d3fdc74c5e SHA512 525791f2be10e118f556676a1645d2805ba6ad920e4f4c8761362c5aa09cf1f773f0216f7b6c2e1f78acbc1de1ac85c6088cc85729af70a28f537fdff3434786
EBUILD rdiscount-2.2.7.1.ebuild 1105 BLAKE2B 7e30f4ef7954abd064ebbbaba7a4a09b93416dd1dccd050851cc1bde6542c56a82634eb74e61e0e70ade1b5daa495e65a9f2b1d1209fa5213893fb8396e88ff4 SHA512 b073bd5f9ee835f328b478c332602d9544591886d270ac1d83a0b5355031d2a862bb53ffae6dd0448c157ef37aa5df41b947906f225116e09783af849b7d9ec0
-MISC metadata.xml 345 BLAKE2B 83db3067d2cf0eeb028bd4793935cb94fe99eb2bff345e02fce72c35613c5c14dc266a8b366a3b518f007b6310ddc3130b3ac1f9a3e52c4940d83bfd6eac1889 SHA512 b771eeb7ff43472f242114cec8f8b1e8dd09715e0b35c1095bfd7d61b1149ec32fc05ea7153704369a270bd267d42ae0e532fab16fc7e6ca11a4454800d72900
+EBUILD rdiscount-2.2.7.3.ebuild 1112 BLAKE2B ced9c875f28a3c644631e3734af8ea4c1b69c0692647c99dd4b755626a0f8abdeeae608f7df9bd0850823aa11933aa47cffc8873e8cf3ca872cd4edce7afe317 SHA512 fed8f421cf81b3515f46d602da7cd5a22ea8c601242e1a261f471757a12774a3a01296d92a00e1257261c973d3e61bc09d56926684943125cf967b0dede5995f
+MISC metadata.xml 399 BLAKE2B 627076125b7e7e5b5e89a7f119f8f53752b736a853df1525686a3ab0e15229fc51dfe0af531d3162bd27b26d1d18e8f0e85d3fe16f505de9149719567a8580ce SHA512 f53507fbea29f248450f54b949387661be9122fabf673179357d6884deb0825426b41f3ea6bd0d19be109023a3c33d8bc2365adb26ee31a65aeaab961443c20b
diff --git a/dev-ruby/rdiscount/metadata.xml b/dev-ruby/rdiscount/metadata.xml
index 7d5116aa1506..b0f9999b842e 100644
--- a/dev-ruby/rdiscount/metadata.xml
+++ b/dev-ruby/rdiscount/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Ruby Project</name>
</maintainer>
<upstream>
- <remote-id type="github">rtomayko/rdiscount</remote-id>
+ <remote-id type="github">davidfstr/rdiscount</remote-id>
+ <remote-id type="rubygems">rdiscount</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ruby/rdiscount/rdiscount-2.2.7.3.ebuild b/dev-ruby/rdiscount/rdiscount-2.2.7.3.ebuild
new file mode 100644
index 000000000000..1e2af68e91bb
--- /dev/null
+++ b/dev-ruby/rdiscount/rdiscount-2.2.7.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_TASK_TEST="test:unit"
+
+RUBY_FAKEGEM_TASK_DOC="doc man"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implementation of John Gruber's Markdown"
+HOMEPAGE="https://github.com/davidfstr/rdiscount"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ # Hanna is broken for us and therefore we don't have it in portage.
+ sed -i -e 's/hanna/rdoc/' Rakefile || die
+
+ # Remove rule that will force a rebuild when running tests.
+ sed -i -e "/task 'test:unit' => \[:build\]/d" Rakefile || die
+
+ # Provide RUBY variable no longer provided by rake.
+ sed -i -e "1 iRUBY=${RUBY}" Rakefile || die
+
+ # Remove obsolete -rubygems argument, bug 775377
+ sed -i -e '/-rubygems/ s:^:#:' Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/rdiscount.1
+}