summaryrefslogtreecommitdiff
path: root/dev-ruby/rdiscount
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-17 07:43:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-17 07:43:56 +0100
commitb978efa000250668b2befa4e2cc96e0afa137611 (patch)
tree0c561efed9b15c17a9d3ef926443f35c58dfb48c /dev-ruby/rdiscount
parentfa5e8e92d94ea9de5d49a1f5ad19abf7272503d0 (diff)
gentoo auto-resync : 17:06:2023 - 07:43:56
Diffstat (limited to 'dev-ruby/rdiscount')
-rw-r--r--dev-ruby/rdiscount/Manifest2
-rw-r--r--dev-ruby/rdiscount/rdiscount-2.2.7.1.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/rdiscount/Manifest b/dev-ruby/rdiscount/Manifest
index 0e2a97dc08e4..402e7f70a85f 100644
--- a/dev-ruby/rdiscount/Manifest
+++ b/dev-ruby/rdiscount/Manifest
@@ -1,3 +1,5 @@
+DIST rdiscount-2.2.7.1.gem 74240 BLAKE2B 06779a601c8d13b90f5d9fb1c38712431671eab1cb2ef012dee284ddb6da254a0c788f16295438913d68f3641db2ec48c7cea3bade4f36fdc55b7a6049119fd4 SHA512 e67bbbb7f19ef14a729642e2059f0920b65a3f254507204955ab6d34529ade643ee7adecc3db2c61ca5462d266f88ea336bd228401e3cd0fad98e2e7763dd8d3
DIST rdiscount-2.2.7.gem 73728 BLAKE2B 0d63372c3e2f4fa1efeef12ec4f8a2b12b9fccd7506ac6609d7e8fea958e04cfa1cc96a484ffba17d643838705d52c1557604ca015fded282ec860a7fc2481a5 SHA512 4f60dc0dbfb6b8f95f80d577c872c2a747d7d15e9fc1f1bd3640f1207a5d262068754dcb6d7b53348fd69de20b85534a390aace35d1eff31112bfbe0f77569d1
+EBUILD rdiscount-2.2.7.1.ebuild 1112 BLAKE2B a99b5c85fc50845508ea24333efb3cbcfa34ce71ef3d6891a14d1fd00efb80159ff0f25038cfaad8d16343f5413c0188adde7652091695e47728f27370e3c79e SHA512 4bbeccc79d3742b2add9fadb5e09a23f6772d5d448a2b1dcfd0a5f0f0e3fe8857986e3cec11ce486fc1f302e69b4a94bec5e3a8d97e4ef44a2f5fb3f14f81d80
EBUILD rdiscount-2.2.7.ebuild 1111 BLAKE2B ce803ed2e4fcf664ced891d93791df3ca2c013113c8d3f94f942a5c0c301aed535c5cabd0bcbaca9af9a097bb3fe48260a7ceea60f08a3afdb0fa05d3c099294 SHA512 7279c56e6e5a214b5c221e61b4c76f772539be2d34cf76b6e8868c17965308a848e5ed03b4dd1f10dc4b66bc744732a4b56385d7f70c3d186c454aa41f910c8b
MISC metadata.xml 345 BLAKE2B 83db3067d2cf0eeb028bd4793935cb94fe99eb2bff345e02fce72c35613c5c14dc266a8b366a3b518f007b6310ddc3130b3ac1f9a3e52c4940d83bfd6eac1889 SHA512 b771eeb7ff43472f242114cec8f8b1e8dd09715e0b35c1095bfd7d61b1149ec32fc05ea7153704369a270bd267d42ae0e532fab16fc7e6ca11a4454800d72900
diff --git a/dev-ruby/rdiscount/rdiscount-2.2.7.1.ebuild b/dev-ruby/rdiscount/rdiscount-2.2.7.1.ebuild
new file mode 100644
index 000000000000..2bdd888ed424
--- /dev/null
+++ b/dev-ruby/rdiscount/rdiscount-2.2.7.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_TASK_TEST="test:unit"
+
+RUBY_FAKEGEM_TASK_DOC="doc man"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implementation of John Gruber's Markdown"
+HOMEPAGE="https://github.com/davidfstr/rdiscount"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ # Hanna is broken for us and therefore we don't have it in portage.
+ sed -i -e 's/hanna/rdoc/' Rakefile || die
+
+ # Remove rule that will force a rebuild when running tests.
+ sed -i -e "/task 'test:unit' => \[:build\]/d" Rakefile || die
+
+ # Provide RUBY variable no longer provided by rake.
+ sed -i -e "1 iRUBY=${RUBY}" Rakefile || die
+
+ # Remove obsolete -rubygems argument, bug 775377
+ sed -i -e '/-rubygems/ s:^:#:' Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/rdiscount.1
+}