summaryrefslogtreecommitdiff
path: root/dev-ruby/regexp_property_values
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-ruby/regexp_property_values
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-ruby/regexp_property_values')
-rw-r--r--dev-ruby/regexp_property_values/Manifest3
-rw-r--r--dev-ruby/regexp_property_values/metadata.xml8
-rw-r--r--dev-ruby/regexp_property_values/regexp_property_values-0.3.4.ebuild43
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-ruby/regexp_property_values/Manifest b/dev-ruby/regexp_property_values/Manifest
new file mode 100644
index 000000000000..e1ea594bce3c
--- /dev/null
+++ b/dev-ruby/regexp_property_values/Manifest
@@ -0,0 +1,3 @@
+DIST regexp_property_values-0.3.4.tar.gz 11273 BLAKE2B a52ab11676b58a752741240912da5fa312661a583dd74a4321f8184fef2864c74e0d5f709cb68e3ce64a3e19e9320305e80bf7614a40142c4855ccec1c40b5a5 SHA512 01ca50f831bf3364e38559e06cb54faef59fdb0b995a6bfa0aaa3943591d98f97939a47911bf8b075b34b3c401b5de51e42a71088400112ee8afd8d39f164465
+EBUILD regexp_property_values-0.3.4.ebuild 1243 BLAKE2B eff393d0962cdd31d0bb616fa9a0be7cb51adf0cff41ff0489ad6d406491298e13fe004afd08f1b93463220979970a0d9a64a62ffe7409a8f28cc5e7513a8170 SHA512 660d1ee28056a2a1d97cc5f08a6f0545c13c69bbf56e2b1637a6b4981574060f69123cea9fb52abcccf2a5419f9a6fb1431ddca2c9bdd76d6a8f9a1549dfd423
+MISC metadata.xml 247 BLAKE2B 7717702c51c35b2a20983332abc6218047b2b5036e6b4c09d3d58b4339e8f9e776879cd116cfda60d3bcf4188859993fb9f3f779aaf595f155d53e85288f3dcc SHA512 ea4c044637b751a2c28c6ac226121e74ef18196af4b594e60413fec907bbab29c6b0c7735c3f503485df16dcfb36ddb86038394d92e2cd18c8f04626628e9f09
diff --git a/dev-ruby/regexp_property_values/metadata.xml b/dev-ruby/regexp_property_values/metadata.xml
new file mode 100644
index 000000000000..28ab0c15f206
--- /dev/null
+++ b/dev-ruby/regexp_property_values/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/regexp_property_values/regexp_property_values-0.3.4.ebuild b/dev-ruby/regexp_property_values/regexp_property_values-0.3.4.ebuild
new file mode 100644
index 000000000000..93ab3b93bc45
--- /dev/null
+++ b/dev-ruby/regexp_property_values/regexp_property_values-0.3.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="See which property values are supported by the regular expression engine"
+HOMEPAGE="https://github.com/janosch-x/regexp_property_values"
+SRC_URI="https://github.com/janosch-x/regexp_property_values/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid dependency on character_set which would lead to circular
+ # dependencies.
+ sed -i -e '/returns a CharacterSet/askip "gentoo circular dependencies"' spec/regexp_property_values/extension_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/regexp_property_values extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/regexp_property_values V=1
+ cp ext/regexp_property_values/regexp_property_values.so lib/regexp_property_values/ || die
+}