summaryrefslogtreecommitdiff
path: root/dev-ruby/rex-exploitation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/rex-exploitation
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/rex-exploitation')
-rw-r--r--dev-ruby/rex-exploitation/Manifest3
-rw-r--r--dev-ruby/rex-exploitation/metadata.xml12
-rw-r--r--dev-ruby/rex-exploitation/rex-exploitation-0.1.19.ebuild31
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/rex-exploitation/Manifest b/dev-ruby/rex-exploitation/Manifest
new file mode 100644
index 000000000000..e647b8b4d1ef
--- /dev/null
+++ b/dev-ruby/rex-exploitation/Manifest
@@ -0,0 +1,3 @@
+DIST rex-exploitation-0.1.19.gem 79360 BLAKE2B 47043054ee9d08775c67d54b31861ad3a454a487bdc47beb135942e267040de7611308c62a23cbf853d190fb8f88c52998dfe3b24f66a698e76e273b6a69d822 SHA512 244de5259e3f4f645df09d1843c34d9ea4f9ea56ba22498495792f192b79a0451810f5c7e73516da5a455c27e61b66f8ccfbc485372946fcedd179b75ff9b31e
+EBUILD rex-exploitation-0.1.19.ebuild 623 BLAKE2B db040a15cc88f665e28bcbe3aa61050ea013d58ae4b250e8a129e9bfcea5dc8b04cfde68573c5c9c6d9e2617751f28cb02ebb61e08b862ad46b46842c04cf882 SHA512 5e1e3c631fbca630730438e837696965a21f1c6a1ef49fa311752fe3361c47cc769732d73857a7e8f0913c2700b5d2e51c11fa285241b10928cc48cc9adf307e
+MISC metadata.xml 405 BLAKE2B f814e2256b6d217a3ee4353eb07d5f5eda723cf7bcf06504ba34df7345584e1feb4320d445b5e5a2c91e9e86948291db47c06c60864954735181ef5bb790c993 SHA512 3af40e7e532b1d0c141aa419cdd5f10dc151c3406e90bc56e7e281a78e8fca7e8204213d6e0ffc6ed74ae4d0ca6a9bc79c5c4760be0406b0d89694d0299d5c85
diff --git a/dev-ruby/rex-exploitation/metadata.xml b/dev-ruby/rex-exploitation/metadata.xml
new file mode 100644
index 000000000000..ca2ed33abcc1
--- /dev/null
+++ b/dev-ruby/rex-exploitation/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rapid7/rex-exploitation</remote-id>
+ <remote-id type="rubygems">rex-exploitation</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rex-exploitation/rex-exploitation-0.1.19.ebuild b/dev-ruby/rex-exploitation/rex-exploitation-0.1.19.ebuild
new file mode 100644
index 000000000000..58d9ec259d80
--- /dev/null
+++ b/dev-ruby/rex-exploitation/rex-exploitation-0.1.19.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="various helper mechanisms for creating exploits"
+HOMEPAGE="https://rubygems.org/gems/rex-exploitation"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/jsobfu:*
+ dev-ruby/metasm:*
+ dev-ruby/rex-arch
+ dev-ruby/rex-encoder
+ dev-ruby/rex-text"
+
+all_ruby_prepare() {
+ sed -i '/bundler/d' Rakefile
+}