summaryrefslogtreecommitdiff
path: root/dev-ruby/rex-nop/rex-nop-0.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
commit2f8db31405fac68eea6f7257d58529243815033b (patch)
tree54259cc8988a98a10586fc0496b1f3501cd1e2a1 /dev-ruby/rex-nop/rex-nop-0.1.1.ebuild
parenta4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (diff)
gentoo resync : 30.04.2018
Diffstat (limited to 'dev-ruby/rex-nop/rex-nop-0.1.1.ebuild')
-rw-r--r--dev-ruby/rex-nop/rex-nop-0.1.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/rex-nop/rex-nop-0.1.1.ebuild b/dev-ruby/rex-nop/rex-nop-0.1.1.ebuild
new file mode 100644
index 000000000000..f322d509abe3
--- /dev/null
+++ b/dev-ruby/rex-nop/rex-nop-0.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rex library for dynamic generation of x86 multi-byte NOPs"
+HOMEPAGE="https://rubygems.org/gems/rex-nop"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rex-arch"
+
+all_ruby_prepare() {
+ sed -i '/bundler/d' Rakefile
+}