summaryrefslogtreecommitdiff
path: root/dev-ruby/rouge/rouge-4.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-20 13:00:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-20 13:00:15 +0000
commite937ca8df21d3186f65edc11c872706c80eb8a61 (patch)
tree6758813cd0a8bd1da09045a9171ff389b1b39718 /dev-ruby/rouge/rouge-4.2.1.ebuild
parent1b5d79237a144dcb8753c783941843d879a906e2 (diff)
gentoo auto-resync : 20:03:2024 - 13:00:14
Diffstat (limited to 'dev-ruby/rouge/rouge-4.2.1.ebuild')
-rw-r--r--dev-ruby/rouge/rouge-4.2.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/rouge/rouge-4.2.1.ebuild b/dev-ruby/rouge/rouge-4.2.1.ebuild
new file mode 100644
index 000000000000..dd5ef6a25191
--- /dev/null
+++ b/dev-ruby/rouge/rouge-4.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+RUBY_FAKEGEM_GEMSPEC="rouge.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser using a strict syntax definition in pure Ruby"
+HOMEPAGE="https://github.com/rouge-ruby/rouge"
+SRC_URI="https://github.com/rouge-ruby/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2 MIT"
+
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="doc test"
+
+ruby_add_bdepend "doc? ( dev-ruby/redcarpet )
+ test? ( dev-ruby/minitest-power_assert )
+ dev-ruby/yard
+"
+
+ruby_add_rdepend "dev-ruby/redcarpet !<dev-ruby/rouge-3.30.0-r1"
+
+all_ruby_prepare() {
+ rm -f tasks/{check/style,update/changelog}.rake || die
+
+ sed -i -e '/bundler/I s:^:#: ; 5irequire "minitest-power_assert"' spec/spec_helper.rb || die
+ sed -i -e '/\(changelog\|bundler\|rubocop\)/ s:^:#: ; 1irequire "pathname"' Rakefile || die
+}