summaryrefslogtreecommitdiff
path: root/dev-ruby/rqrcode/rqrcode-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
commitcc4618c9ba3d974948ebf340b542d8cb01db2f55 (patch)
tree125ee67bb9e0d548771cf7b61d04bb1f0dc57687 /dev-ruby/rqrcode/rqrcode-2.1.0.ebuild
parent677b7ba5c317778df2ad7e70df94b9b7eec4adbc (diff)
gentoo resync : 16.09.2021
Diffstat (limited to 'dev-ruby/rqrcode/rqrcode-2.1.0.ebuild')
-rw-r--r--dev-ruby/rqrcode/rqrcode-2.1.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/rqrcode/rqrcode-2.1.0.ebuild b/dev-ruby/rqrcode/rqrcode-2.1.0.ebuild
new file mode 100644
index 000000000000..e21c22e869e8
--- /dev/null
+++ b/dev-ruby/rqrcode/rqrcode-2.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="rqrcode.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for encoding QR Codes"
+HOMEPAGE="https://whomwah.github.io/rqrcode/"
+SRC_URI="https://github.com/whomwah/rqrcode/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/chunky_png:0
+ dev-ruby/rqrcode_core:1
+"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+}