summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-expectations
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-17 11:37:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-17 11:37:14 +0000
commitf8deb4f754798d63fb6b82178452ee846df8475f (patch)
tree8f187327b54a42741f986268292e3096aadc4019 /dev-ruby/rspec-expectations
parentc4a46526c2232ba00b0ccc97f2d2a30b0c6baea5 (diff)
gentoo auto-resync : 17:02:2024 - 11:37:14
Diffstat (limited to 'dev-ruby/rspec-expectations')
-rw-r--r--dev-ruby/rspec-expectations/Manifest2
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-3.13.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/rspec-expectations/Manifest b/dev-ruby/rspec-expectations/Manifest
index 82066c74cbd7..2a8d7895e698 100644
--- a/dev-ruby/rspec-expectations/Manifest
+++ b/dev-ruby/rspec-expectations/Manifest
@@ -1,5 +1,7 @@
DIST rspec-expectations-3.12.3-git.tgz 218754 BLAKE2B be6c6c50115bec39758f792030363de88abf5affa8a4df1161a386fee3dfb620542fca6225779e76aa2e72d1f782b65ef9db393be061e9ed47c72d96f47cf981 SHA512 37f85555e0ba16b1a76f8d59571312febfc802eab1a27ff788d57bb34f410867e753dcfee83ca3d70367b77ad9f823341c653901c8ff02c75df6863937c71315
DIST rspec-expectations-3.12.4-git.tgz 219529 BLAKE2B 8858b586cb2b50f06c93530304ca554ddff9f3fe7078e1e2f263ab352e8315d3529bd8028b835d8b83d49bc06345a0723d2fbf31849552ef53567f2162eb503c SHA512 9317d91fb5fb02c1319010517df6f28bc117cccb3b8fd4226bd1adde00fbf13d1505be89cd036bd1849b9a142e24ec966afa536144e384700f8d11e640e2eaf9
+DIST rspec-expectations-3.13.0-git.tgz 220792 BLAKE2B 526282d357f47d82163b8a44f5fffc0ce24f0fef0d0f5c5f33da93c91680ae704a065c4903a8b7eb3b619d3910314ff137d1c7b636207c0a3383ed0520e2ffaa SHA512 9e1e502d12704fd7573a57b7f01cf4ffe97e2eefe83dc3144842f460165304dc234a1b1946147f2cbcae105d755c8b42b25aec815f9af0c67844baf858c0a6c7
EBUILD rspec-expectations-3.12.3.ebuild 1402 BLAKE2B 364417588939e7907552fb88cbf1e9d78f2c3b43646afbe7dd8bd9bf690fb9d3bc2b0c18dfe1da61ed4fcd6edf8eb6c3512a9a1b4358328409d6245b1464adb1 SHA512 8b7a5b037c2660c7fd3deb0f064848db36aff182a4d45979909cc5177dcc5f3e0a5e569022a0407be556cc46f32856ca80bd88219915a9528a8c908dd02a298b
EBUILD rspec-expectations-3.12.4.ebuild 1417 BLAKE2B 23a08dfe6e4d874c39f9d5780187f9011d250a90c83cc8dfb1a627be81786f58e7ec095c0f2c9a81182fbc24b769c3f752004f1174dcf25b8e233bba3cb38ae5 SHA512 b668535c975b5c3edc3c200b21c9d38e972f8b5e72b30745417c2e208dc3819a77ff9b849a16cdd0647b66e0f9732cc3863def7a5d827a012ed8e88c36692c07
+EBUILD rspec-expectations-3.13.0.ebuild 1417 BLAKE2B 23a08dfe6e4d874c39f9d5780187f9011d250a90c83cc8dfb1a627be81786f58e7ec095c0f2c9a81182fbc24b769c3f752004f1174dcf25b8e233bba3cb38ae5 SHA512 b668535c975b5c3edc3c200b21c9d38e972f8b5e72b30745417c2e208dc3819a77ff9b849a16cdd0647b66e0f9732cc3863def7a5d827a012ed8e88c36692c07
MISC metadata.xml 351 BLAKE2B d819679f0a74e7885241c77f001e1522143ea052a1cd511d128c3321aa96d6060b98ef11c615165f631d4081f5757c7ed463de58f44acb6187d026ce86a2042c SHA512 1f43d7394a1fc32d2aae92b66a513af0572ee1ed4bed3d391b4774df97919113ec9ec9d0da68e26f1c5558d877e1c8fef01aca6b92ce6b70bc3b256ad70dade0
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-3.13.0.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-3.13.0.ebuild
new file mode 100644
index 000000000000..96e2fb7e5b11
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-3.13.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-expectations"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+SUBVERSION="$(ver_cut 1-2)"
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.2.0 =dev-ruby/diff-lcs-1*
+ =dev-ruby/rspec-support-${SUBVERSION}*"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-mocks-3.2.0:3
+ >=dev-ruby/rspec-support-3.5.0:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Fix minitest deprecation
+ sed -i -e 's/MiniTest/Minitest/' spec/rspec/expectations/minitest_integration_spec.rb || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm -f Gemfile || die
+
+ # fix up the gemspecs
+ sed -i \
+ -e '/git ls/d' \
+ -e '/add_development_dependency/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+}