summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-its
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/rspec-its
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/rspec-its')
-rw-r--r--dev-ruby/rspec-its/Manifest3
-rw-r--r--dev-ruby/rspec-its/metadata.xml11
-rw-r--r--dev-ruby/rspec-its/rspec-its-1.2.0-r1.ebuild30
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/rspec-its/Manifest b/dev-ruby/rspec-its/Manifest
new file mode 100644
index 000000000000..b4d951ef81c3
--- /dev/null
+++ b/dev-ruby/rspec-its/Manifest
@@ -0,0 +1,3 @@
+DIST rspec-its-1.2.0.gem 12800 BLAKE2B ac9cb1899c2c1c88ab61617bb4fb30fffba572623dede0c6bbecebb12f36d12d7e7aa94ebe584333228d63fe3332ea978a8b8b95489cc7530942d3ec33c12faa SHA512 6b390f92654f8e6482f0da30d4e721ee127f628eb305268e474d4c9fb14fca1d0fb8922cabc9a8c1372976b5a52349c5a5a774e3026f32d8050c5aea2bc9ccae
+EBUILD rspec-its-1.2.0-r1.ebuild 722 BLAKE2B 9ec14d35752c0083556afb7ca9b69e5dbcb65c4c8d07d28ed8624265025c2d4ad6de73170ad54cbc46e29aa131032e339ef5d856a817d4e768ebfa00a1a8dab2 SHA512 1937c53dc818a8604f48c9f310fad24e1f2aeda9727e45cf407895382088500fa6008cd573a52399cc6105d32d21c85b82ce7ec474f9ec93ddb02d6163387ee7
+MISC metadata.xml 341 BLAKE2B 2d94ba5cc1c27593199becf0754c35ed399d908b21a2165a2c40fef13e609d321484653a6b32b73778091f9be7734654534a8d2a2b4583e5df86f5713d0003e9 SHA512 5433a1938d9094ff13d5473895758e44814d6eb241c523fd21bc2ad9854c6eb4be2a88364b0dff3a6625eb85c4302d969f64e6b834aca8a354e57f0288a2a6b1
diff --git a/dev-ruby/rspec-its/metadata.xml b/dev-ruby/rspec-its/metadata.xml
new file mode 100644
index 000000000000..6b588d02ba14
--- /dev/null
+++ b/dev-ruby/rspec-its/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rspec/rspec-its</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rspec-its/rspec-its-1.2.0-r1.ebuild b/dev-ruby/rspec-its/rspec-its-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..b85a6501ac5b
--- /dev/null
+++ b/dev-ruby/rspec-its/rspec-its-1.2.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-its"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~ppc ~ppc64 x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rspec-core-3.0.0 >=dev-ruby/rspec-expectations-3.0.0"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby24|*ruby25)
+ sed -i -e 's/Fixnum/Integer/' spec/rspec/its_spec.rb || die
+ ;;
+ esac
+}