summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0.ebuild')
-rw-r--r--dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0.ebuild b/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0.ebuild
new file mode 100644
index 000000000000..b95f3edd5c66
--- /dev/null
+++ b/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Set of matchers and helpers to allow you test your APIs responses."
+HOMEPAGE="https://github.com/waterlink/rspec-json_expectations"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-util/cucumber )"
+
+each_ruby_test() {
+ ${RUBY} -S cucumber --format progress features || die
+}