summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-gobject-introspection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /dev-ruby/ruby-gobject-introspection
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'dev-ruby/ruby-gobject-introspection')
-rw-r--r--dev-ruby/ruby-gobject-introspection/Manifest2
-rw-r--r--dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.3.6.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/ruby-gobject-introspection/Manifest b/dev-ruby/ruby-gobject-introspection/Manifest
index 36caae8914ad..956f531b188b 100644
--- a/dev-ruby/ruby-gobject-introspection/Manifest
+++ b/dev-ruby/ruby-gobject-introspection/Manifest
@@ -1,3 +1,5 @@
DIST ruby-gnome2-all-3.3.2.tar.gz 2310841 BLAKE2B 8f50dc289cd097fa476a3419ffec623009395384bcfa965803f3e4e857e095866e0233e7546150c5e54d1e35f71c5e72a2880100a881ba037356208e5d3721ce SHA512 4581aad8c69db2b6be3b067ff60994fb3567d68299f634e085319ac81f51e1d681972ccba715f8e93df3adba155fa8cd3a49929cd77f6eb01856be30e551b21c
+DIST ruby-gnome2-all-3.3.6.tar.gz 2307419 BLAKE2B 80d981528a7d1ff41400e8555c7576ac299a5e3b7d3fc7f78843ae0bedfa6ad43c79d3ebef60b918236c9054b0e5de462b48a274d1fdd03f6f288ff53d6645a5 SHA512 8bcd439cee77efc70423eeec43380f080b348627384c675e3b3a810e602b5da4f04bc476eccabdf009a442d496442e7a45a23f126bde4b356af70ac9949c27f5
EBUILD ruby-gobject-introspection-3.3.2.ebuild 1064 BLAKE2B 58395216023484a4eddbecc51d39ef4181034ae31535d0ae60ae87e31269fc89d955c587e64cd369cdc990fdeabdc96b05302c89e977dcf65e31b5dce5588a61 SHA512 2afddec38dca9c32b3e5b79fe338f52ac8c3dfc02d54e3377bb7928f3e522ecf361d8dde8e29d9d598396309c8c3f22e917101abba3be82b68167393d60ca8e1
+EBUILD ruby-gobject-introspection-3.3.6.ebuild 1051 BLAKE2B 8a7cc0ca7691fd8676a319bac7179b0bb7c9add3555238adfe0428a81cd23fbe88bfab96ed60e3a01bfbba14d34714238142df7fcab50dbe9645367d70458cc5 SHA512 23000a36802cb89711e747fe3d4a0d720409b61a38a964b51cb64942a1c2733d6ed089cafb13ce0443f05367f3ef246d237b31c001432f747d6d09b0fbcd2065
MISC metadata.xml 391 BLAKE2B b68c9928d0cae2572bb8737d6a9b5aa90acd0fea2ef7c1de4fa0e2079685cb69b508107f6c651e21fe747d86a4caf0a7171086b2bd6c35af0721cde99f7ec8f3 SHA512 84903daa0e4584dd1e631df4a25becbd4e1a599c998d0384978fa82d971a6fd119e920fd0e4830771a98efd3075f1529a6bfbd64739bdecaa22ec70f31be1ab2
diff --git a/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.3.6.ebuild b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.3.6.ebuild
new file mode 100644
index 000000000000..2cb9544a2609
--- /dev/null
+++ b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.3.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+inherit ruby-ng-gnome2
+
+RUBY_S=ruby-gnome2-all-${PV}/gobject-introspection
+
+DESCRIPTION="Ruby GObjectIntrospection bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND+=" dev-libs/gobject-introspection"
+RDEPEND+=" dev-libs/gobject-introspection"
+
+ruby_add_rdepend "~dev-ruby/ruby-glib2-${PV}"
+
+all_ruby_prepare() {
+ # Remove pregenerated Makefile since it will otherwise be shared by all targets.
+ rm -f Makefile Makefile.lib ext/gobject-introspection/Makefile || die
+
+ # Avoid native installer
+ sed -i -e '/native-package-installer/ s:^:#: ; /^\s*setup_homebrew/ s:^:#:' ../glib2/lib/mkmf-gnome2.rb || die
+
+ # Avoid unneeded dependency on test-unit-notify.
+ sed -i -e '/notify/ s:^:#:' test/gobject-introspection-test-utils.rb || die
+
+ # Avoid compilation of dependencies during test.
+ sed -i -e '/system/,/^ end/ s:^:#:' test/run-test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}