summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-gobject-introspection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-01 02:06:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-01 02:06:43 +0000
commitc635a4b7ddb6105bfc6fef130b188a087726677b (patch)
tree6707959596af4883f9621a0cdf56d35c06dbc63e /dev-ruby/ruby-gobject-introspection
parent080d89feff80cae2fc974ff2f24d463141c20635 (diff)
gentoo auto-resync : 01:12:2024 - 02:06:42
Diffstat (limited to 'dev-ruby/ruby-gobject-introspection')
-rw-r--r--dev-ruby/ruby-gobject-introspection/Manifest2
-rw-r--r--dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-4.2.4.ebuild17
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-ruby/ruby-gobject-introspection/Manifest b/dev-ruby/ruby-gobject-introspection/Manifest
index 06529c1becb1..a933347017fc 100644
--- a/dev-ruby/ruby-gobject-introspection/Manifest
+++ b/dev-ruby/ruby-gobject-introspection/Manifest
@@ -1,3 +1,5 @@
DIST ruby-gnome2-4.1.2.tar.gz 2708791 BLAKE2B ef24788d8c65f96c76b43d8adc38af21dfb3bfe2f8ae2157f6978993fe65e9735030e9912e8eb1ff5ff90ab1c67701ae61ac3b0790cb285646f26b6193d74be5 SHA512 898ae5bcd7a6347d7392b7888c19493905f6e660afb61f17a60b1f22e4069329ef6ccc9277375a2c40b4d998a309b61de6797f50c4633c0f5de22d2e85252537
+DIST ruby-gnome2-4.2.4.tar.gz 2748574 BLAKE2B 8203e964a64c4699edce1c12559d3ee25f772b600c9f9af97ca6a133bb7b7a5773d8e6ca76a380a435daeb92ee03a57534e193a3436f13bac572e866c3655be5 SHA512 8efb04324255e3db17cd9a1a3c6984edb2b523e62493740c90a2cc48b957bcb6849438658273c00f2b6bcb497a6314b9f058eede789cc8625bee6145cfb799bb
EBUILD ruby-gobject-introspection-4.1.2.ebuild 423 BLAKE2B ac10d458d6922b51497ab0eccc5323bd78028ba30f1e374335617efaf534b5bd812ad4a706561bfe1a49ce5e490aa7a95aa9fc47a1193d9bc52caf562ef5cac3 SHA512 4cef3530b087eca66730e667884ecff82be3102e23f5feab21b8f8bfe357e2cafa1d8162fe4a004f426f51e165990079ecd8e84ce093891c3bf999c8f411f944
+EBUILD ruby-gobject-introspection-4.2.4.ebuild 412 BLAKE2B 15295b1cf4b865a5a37822ea4e57ad92d2b235bb9194ee48cef5769b0bff5bc7a1befb80e86de987ea99d74bb0587dd6c4ab0bc61afd090647174cace10d3df2 SHA512 545e8dc284f7d5294a0961d1a885c19861667136225b0bdfedf91cbc67f35916b5e094d40860957f1b8d7b001a992bd4b6e65246fa67fdf123229778aa47674a
MISC metadata.xml 338 BLAKE2B 28afb4e4601ddbd918344e8ea4668d18b43122fd5db29849d806919be9da2889d21fa047bfc43cbad6c95ff0e0f1bcdba2c2ba0c5e0b8b27ac7a235f534cd163 SHA512 72c7dbc3d22142137d4017e7514cafc7c900b673a571b44b7c649dc8776550d504052cce7f48164594939f1cd01e0fa5034a1e8c3b9c4a5f7176f7760ba692da
diff --git a/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-4.2.4.ebuild b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-4.2.4.ebuild
new file mode 100644
index 000000000000..11c26e7558c7
--- /dev/null
+++ b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-4.2.4.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+inherit ruby-ng-gnome2
+
+DESCRIPTION="Ruby GObjectIntrospection bindings"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+
+DEPEND="dev-libs/glib
+ dev-libs/gobject-introspection"
+RDEPEND="dev-libs/glib
+ dev-libs/gobject-introspection"
+
+ruby_add_rdepend "~dev-ruby/ruby-glib2-${PV}"