summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-ldap/ruby-ldap-0.9.20-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 16:50:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 16:50:39 +0100
commit3be8faef74cb863e207124a6fccbf01ce90c0799 (patch)
tree222958402b707645e8b7bcb072c607c538f2f5c0 /dev-ruby/ruby-ldap/ruby-ldap-0.9.20-r5.ebuild
parentea3e1bbf643d1d8892f4df05e4f05c1b2a2125d8 (diff)
gentoo auto-resync : 15:09:2023 - 16:50:39
Diffstat (limited to 'dev-ruby/ruby-ldap/ruby-ldap-0.9.20-r5.ebuild')
-rw-r--r--dev-ruby/ruby-ldap/ruby-ldap-0.9.20-r5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/ruby-ldap/ruby-ldap-0.9.20-r5.ebuild b/dev-ruby/ruby-ldap/ruby-ldap-0.9.20-r5.ebuild
new file mode 100644
index 000000000000..9230db150bd6
--- /dev/null
+++ b/dev-ruby/ruby-ldap/ruby-ldap-0.9.20-r5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTENSIONS=(./extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="ChangeLog FAQ NOTES README TODO"
+
+DESCRIPTION="A Ruby interface to some LDAP libraries"
+HOMEPAGE="https://github.com/bearded/ruby-ldap"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="ssl"
+DEPEND=">=net-nds/openldap-2:=
+ dev-libs/cyrus-sasl
+ ssl? ( dev-libs/openssl:0= )"
+RDEPEND="${DEPEND}"
+
+# Current test set is interactive due to certificate generation and requires
+# running LDAP daemon
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.20-clang16-fix.patch
+ "${FILESDIR}"/${PN}-0.9.20-ruby32.patch
+ "${FILESDIR}"/${PN}-0.9.20-tainted.patch
+)
+
+each_ruby_configure() {
+ local myconf="--with-openldap2"
+ if ! use ssl ; then
+ myconf="${myconf} --without-libcrypto --without-libssl"
+ fi
+ RUBY_FAKEGEM_EXTENSION_OPTIONS=${myconf} each_fakegem_configure
+}