summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-prof
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
commit6c30cc2d5bd48ddbdbe8d75544899cd5dbfcaba4 (patch)
tree6ef7f6e1d48141a5da904d788b906da5bba4b697 /dev-ruby/ruby-prof
parent62f82c107c3904ac6917ece47301d2999c7dd90e (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/Manifest2
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.16.2.ebuild62
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-ruby/ruby-prof/Manifest b/dev-ruby/ruby-prof/Manifest
index fad338d2dde0..e0fa2403e8cc 100644
--- a/dev-ruby/ruby-prof/Manifest
+++ b/dev-ruby/ruby-prof/Manifest
@@ -1,5 +1,3 @@
-DIST ruby-prof-0.16.2.tgz 87039 BLAKE2B 89a06edd36e7e70b978ce56b4cfea04f871538d2c35f25be3e46049d7fea863ad91006f87aa7ffb9afa4416c3e2aaafb7774c93804476dbc746b764c86d01c0e SHA512 4a070486375a40afd03c006385a14f5d2ae3670a658e1153b086d0e63eb7a87af38ae060c9d457cd67a5e084f75dd997cd39b890ef4a510bbae801838f74f7f8
DIST ruby-prof-0.17.0.tgz 93492 BLAKE2B e573b77fb5f1134af99480efe3af706cade122c51bbef883cf0f915e359c695fe70485239fee7415288e99115146230bc803ec1976a39c6f5d743c10f0158744 SHA512 4e2a542420eced379a0326c0f48a041379a7a2aa06247e5cd9659f92b44ebcfca21d12a7bdf50f23ef0bdd6b37895b963a489a975ca84d487920c8fe52446d53
-EBUILD ruby-prof-0.16.2.ebuild 1590 BLAKE2B 4c6c5dfb11e9892715db60979e12d00648fd8daef722844aca1bd74812cc10c90e509e50bdbe822173c1e77db75b5af19358ce968e1e828e106fd6016f4fe4c6 SHA512 376ffdeddc9bb37f668513e597a0a56a3c1d5beb9ebc6fba4fbff2dcff9be1b4815145bb08847e52c068b1f02a198c2e324ca20c5339c6e21ad695f09a968786
EBUILD ruby-prof-0.17.0.ebuild 1590 BLAKE2B 8334b9a3e32cb62b57c8faacf82041567c0b25e0d956b83e15df785ae2fe59296314a2d195036156879e86241e18b11221db0aba10ba5de772d33f932ebcf983 SHA512 f5dbea29ba2b662736fac9e8740cf75a84bf8193ed1b6c84061986c8a88a0cfeead129266e6a4b4416c597153213a78a722684c6204aa9a096842a575e282204
MISC metadata.xml 345 BLAKE2B abf08843e05ea5a260b8d3b1de88259aa5b593ef0be34c9066cc9f53aec48f13e962ee77224e28b7253f45850af20222d672578f57111bbca2d250458515c26d SHA512 e1647ce0131d640e8de67cdaf4bedd36d5cf3cc1d251e08b3f36a7c82bf356f80a3911984adbe14d25250b2f5c3333a988b5baed8978adea0b68594d985f22ef
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.16.2.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.16.2.ebuild
deleted file mode 100644
index 65a6ba3cbdaa..000000000000
--- a/dev-ruby/ruby-prof/ruby-prof-0.16.2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A module for profiling Ruby code"
-HOMEPAGE="https://github.com/ruby-prof/ruby-prof"
-SRC_URI="https://github.com/ruby-prof/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/minitest )"
-
-all_ruby_prepare() {
- # Avoid bundler
- sed -i -e '/bundler/I s:^:#:' -e '/:build/ s:^:#:' Rakefile || die
-
- sed -i -e '2igem "test-unit"' test/test_helper.rb || die
-
- # Fix a timing-dependant spec since its thresholds for success are
- # too tight.
- sed -i -e '/test_class_methods/,/^ end/ s:^:#:' test/measure_cpu_time_test.rb || die
-
- # We install the shared object in lib, not ext.
- sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb || die
-
- # Avoid unneeded dependency on rake-compiler
- sed -i -e '/extensiontask/ s:^:#:' \
- -e '/ExtensionTask/,/end/ s:^:#:' Rakefile || die
-
- # Create directory required for the test suite to pass
- mkdir tmp || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/ruby_prof || die "build failed"
-
- cp ext/ruby_prof/*$(get_modname) lib/ || die "copy of extension failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- for dir in examples ; do
- docinto "$dir"
- dodoc -r "$dir"/*
- done
-}