summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-progressbar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-23 12:45:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-23 12:45:14 +0000
commitc8c3804588db08dae281504dd79ef71741cd8dc3 (patch)
treec0dc730627dd25f276c533a00e6b763b8eef1f56 /dev-ruby/ruby-progressbar
parentdd5b71d2ad69f1887985ee1ca67b254e04157f73 (diff)
gentoo auto-resync : 23:03:2023 - 12:45:13
Diffstat (limited to 'dev-ruby/ruby-progressbar')
-rw-r--r--dev-ruby/ruby-progressbar/Manifest2
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/ruby-progressbar/Manifest b/dev-ruby/ruby-progressbar/Manifest
index 5b07a796afac..aa6499e2f562 100644
--- a/dev-ruby/ruby-progressbar/Manifest
+++ b/dev-ruby/ruby-progressbar/Manifest
@@ -1,3 +1,5 @@
DIST ruby-progressbar-1.11.0.tar.gz 61341 BLAKE2B 558de9d15f6c3eafb0a9ef0b39db279727651c8f86234f3ffad1faac7e9ab7f6bdef6662fadb2132bf10d70bcac9412801a695e0bb3afa5879a48dd363920734 SHA512 5a5c8a6af410746ef601821ec171933d781d32bfb7cb5f67f9cf877824a399941c11be69bb74380941f2271f6f5139928599881441f88860a71f8b7f7b55d4b4
+DIST ruby-progressbar-1.13.0.tar.gz 67185 BLAKE2B 27ea25e4caeb70aefb2523a4f4399056bdb9973deb567fc80eb9daeab6193ecc3693c8364bb43fc94906e6b63a0db1ace6bbd9b00defa0e02177983371b54ad3 SHA512 64723422d6216f2640bc60c8068c8d0437fbc5f315343b13c3167130d868a0aa978f098554ace3ea71406688c0b3c0ed94296adc6b9229ea14df5dbcb56322a3
EBUILD ruby-progressbar-1.11.0.ebuild 913 BLAKE2B 39bf83cd8cbbef87bbbc675b466b7c9a48e9416c9a481b8a1a5456d90647f176d2a238c0cb12b66086e6a6d4a43a3d302019e557f1aab35124ed0cecdfc080da SHA512 40f4422b4fe108b96bed0b740f3ef86129131a76b3e090ec0cd808c9b572f51908f07747544eb71c670e6e6d567970dad9aa027234dc97cd0698483d88da0ea4
+EBUILD ruby-progressbar-1.13.0.ebuild 897 BLAKE2B e1206d49d69e6f941c5b0d2a4876211dc9fbe2beb1e162e42c6a0b6fa12ab6fa5201685706090c7b0f56ac5b928ca3239510e4490cb2a2f70b6315eb2969cf2b SHA512 5253e3a9a65889d929a0de5a7df894108f59491e079b46eac5cf019ace76d89a40487878aa935d8184df4444994af244f24cc3d07d82777c76e58b575af82f40
MISC metadata.xml 353 BLAKE2B 7805fc15a01ee29282bd6097c97659acdd06e1437042d9ff67f2eec8fa0800361e143741cb28436a890ab4952777587e8058c5a6c40d6d6100d5aad7e47f160d SHA512 b98e1e7fae3dd752ec27801aec152ec007d11cec4bdbd125b906ef42797052a5f7ab1dc8e718f133243a309a4aba267d4bc0caba41701b25bab13bb4442f4f7e
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0.ebuild
new file mode 100644
index 000000000000..b77912c368ba
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="ruby-progressbar.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="https://github.com/jfelchner/ruby-progressbar"
+SRC_URI="https://github.com/jfelchner/ruby-progressbar/archive/releases/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-progressbar-releases-v${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+ruby_add_bdepend "test? ( dev-ruby/rspectacular dev-ruby/timecop )"
+
+all_ruby_prepare() {
+ sed -i -e '/warning_filter/ s:^:#:' \
+ spec/spec_helper.rb || die
+}