summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-shout/ruby-shout-2.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/ruby-shout/ruby-shout-2.2.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/ruby-shout/ruby-shout-2.2.2.ebuild')
-rw-r--r--dev-ruby/ruby-shout/ruby-shout-2.2.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/ruby-shout/ruby-shout-2.2.2.ebuild b/dev-ruby/ruby-shout/ruby-shout-2.2.2.ebuild
new file mode 100644
index 000000000000..377d1f0fa367
--- /dev/null
+++ b/dev-ruby/ruby-shout/ruby-shout-2.2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.textile"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby interface to libshout2"
+HOMEPAGE="https://github.com/niko/ruby-shout"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND+=" >=media-libs/libshout-2.0"
+DEPEND+=" >=media-libs/libshout-2.0"
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die "extconf failed"
+}
+
+each_ruby_compile() {
+ emake -C ext V=1
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ ruby_fakegem_newins ext/${PN#ruby-}_ext$(get_modname) lib/${PN#ruby-}_ext$(get_modname)
+}