summaryrefslogtreecommitdiff
path: root/dev-ruby/securerandom/securerandom-0.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-07 10:17:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-07 10:17:51 +0000
commite0fac29676c44b996e61c06f8d5c92288e46966b (patch)
treebe619e692a42f1a90900cca21b19a2ec88404f8d /dev-ruby/securerandom/securerandom-0.3.0.ebuild
parent639971d0c3ee4eef36854ab7d9729b6e8c3ac1cb (diff)
gentoo auto-resync : 07:11:2023 - 10:17:51
Diffstat (limited to 'dev-ruby/securerandom/securerandom-0.3.0.ebuild')
-rw-r--r--dev-ruby/securerandom/securerandom-0.3.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/securerandom/securerandom-0.3.0.ebuild b/dev-ruby/securerandom/securerandom-0.3.0.ebuild
new file mode 100644
index 000000000000..234e636a26d7
--- /dev/null
+++ b/dev-ruby/securerandom/securerandom-0.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="securerandom.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Interface for secure random number generator"
+HOMEPAGE="https://github.com/ruby/securerandom"
+SRC_URI="https://github.com/ruby/securerandom/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}