summaryrefslogtreecommitdiff
path: root/dev-ruby/simplecov_json_formatter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-ruby/simplecov_json_formatter
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-ruby/simplecov_json_formatter')
-rw-r--r--dev-ruby/simplecov_json_formatter/Manifest3
-rw-r--r--dev-ruby/simplecov_json_formatter/metadata.xml11
-rw-r--r--dev-ruby/simplecov_json_formatter/simplecov_json_formatter-0.1.4.ebuild22
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/simplecov_json_formatter/Manifest b/dev-ruby/simplecov_json_formatter/Manifest
new file mode 100644
index 000000000000..ac4bff87cae3
--- /dev/null
+++ b/dev-ruby/simplecov_json_formatter/Manifest
@@ -0,0 +1,3 @@
+DIST simplecov_json_formatter-0.1.4.gem 6656 BLAKE2B 57a03ca27911ed798ec2aa7e84a8d037e4565b0b9fec261d0a72d9276355ba27eb8fedea31195bc8b6e6b67b94b9a5f903f326720b862a46790bacd282e83c63 SHA512 1b90167acf4ad9565084488b455ee25ab8930a70a849191228e2868c15f29d257dc5256bb578e11351a942d887dcdeda9191a541cd0fb70e3f0eb8466fb13ddf
+EBUILD simplecov_json_formatter-0.1.4.ebuild 559 BLAKE2B dd3f670e68787b7eb6212eaeaa70eae2a2105e61f8f4da3d4568d0a70895570ec5e401e925eef767eef2020efbfc0fafed170b47b4feb4c1f972d73bc1ac8f36 SHA512 bbe251c542b3da91bba53aec4c6b0d865fe68f90497c9af9852859895e3c46428e0ccf888fbda1d0ebcc0dac3bf28448986837d2855420f13e160a8f980db51d
+MISC metadata.xml 373 BLAKE2B d51ce0a2133dbec724c53fc30da13cf13582b832d454695d9220fa45c0f8ac0614707093cb03be5ec8203b1b078f8baa46c44c92d562c41c0eb8925eba1607d6 SHA512 359e2689c8d0897dd07c51dd837308dfbe402cff8f9989bdc31e087aaaf903ac9f7db9a18411a304815672f000b6533942235aa1543da4b66d7d9232f503fa68
diff --git a/dev-ruby/simplecov_json_formatter/metadata.xml b/dev-ruby/simplecov_json_formatter/metadata.xml
new file mode 100644
index 000000000000..0670a7dfae0d
--- /dev/null
+++ b/dev-ruby/simplecov_json_formatter/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">codeclimate-community/simplecov_json_formatter</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/simplecov_json_formatter/simplecov_json_formatter-0.1.4.ebuild b/dev-ruby/simplecov_json_formatter/simplecov_json_formatter-0.1.4.ebuild
new file mode 100644
index 000000000000..5201e28824d9
--- /dev/null
+++ b/dev-ruby/simplecov_json_formatter/simplecov_json_formatter-0.1.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="JSON formatter for SimpleCov"
+HOMEPAGE="https://github.com/codeclimate-community/simplecov_json_formatter"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~riscv"
+SLOT="$(ver_cut 1)"
+IUSE="doc"
+
+# Not packaged in the gem and very fragile for e.g. simplecov versions
+RESTRICT="test"