summaryrefslogtreecommitdiff
path: root/dev-ruby/simpleidn/simpleidn-0.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-ruby/simpleidn/simpleidn-0.2.1.ebuild
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-ruby/simpleidn/simpleidn-0.2.1.ebuild')
-rw-r--r--dev-ruby/simpleidn/simpleidn-0.2.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/simpleidn/simpleidn-0.2.1.ebuild b/dev-ruby/simpleidn/simpleidn-0.2.1.ebuild
new file mode 100644
index 000000000000..f446bb84e2af
--- /dev/null
+++ b/dev-ruby/simpleidn/simpleidn-0.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+RUBY_FAKEGEM_EXTRAINSTALL="tables"
+
+RUBY_FAKEGEM_GEMSPEC="simpleidn.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows easy conversion from punycode ACE to unicode UTF-8 strings and vice-versa"
+HOMEPAGE="https://github.com/mmriis/simpleidn"
+SRC_URI="https://github.com/mmriis/simpleidn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/unf-0.1.4 =dev-ruby/unf-0.1*"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}