summaryrefslogtreecommitdiff
path: root/dev-ruby/singleton
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-10 03:03:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-10 03:03:09 +0000
commitbe94ae04eee564451203d45977c2ef7c7ace1580 (patch)
tree616ffc0ad9aee18dc7d5e9e62bf62394e8e520ba /dev-ruby/singleton
parent2be329ae14bbf99f0fc4de7567e2386bbb529fdc (diff)
gentoo auto-resync : 10:11:2024 - 03:03:09
Diffstat (limited to 'dev-ruby/singleton')
-rw-r--r--dev-ruby/singleton/Manifest2
-rw-r--r--dev-ruby/singleton/singleton-0.3.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/singleton/Manifest b/dev-ruby/singleton/Manifest
index 94c4ca99ff79..a81e260e8d0d 100644
--- a/dev-ruby/singleton/Manifest
+++ b/dev-ruby/singleton/Manifest
@@ -1,3 +1,5 @@
DIST singleton-0.2.0.tar.gz 5179 BLAKE2B 8d0ed2fb38ff8fc8bd5da3969c4e0dcc3c5556b69dfa7faceb9d02d80b69d902418d54b8a313188927938adb1431fa593aaea0249109c34b809c6d3a35ba08b4 SHA512 e6c827f277754fc20722afbf20c67b22fc44095337777e69afa0eff8c88390be86741b244ee35124fc2684fbe048d439dfe96499617ec672275fdd7e64d36e43
+DIST singleton-0.3.0.tar.gz 6955 BLAKE2B 55a499dbb2a8915d9aba0a38ce32146a8ae4475dbe5b446ed036f1bc509bce6ba2d25aa3cadc96c147526adb43545f75dabe010c720a4fadd7dbf63a81af7d6b SHA512 f703ab194b97018cded9ce09877e9d7d8715f4f605c43b66ab92580188784a4740234fec54e28b0e31386f717d1420dc2486458d8ccedbc07f40e61e3f1598d7
EBUILD singleton-0.2.0.ebuild 942 BLAKE2B 20b890d850b29801d5618e8122f73105168fc4dbf6dd3943f2dfc352ab2239f975952e0148f583f476d6b8379e5a1dfe6921cc06cb4267fee25ca7a6b8e21955 SHA512 f30cbf71bb8a5c5b36c1fc5a76fcbc4a2b2dbfdfe47cea3321caa03960afba1abf569453456fc645ab15bc1b6013da6e85f5480aadab438fd4d8392d771ae7ff
+EBUILD singleton-0.3.0.ebuild 941 BLAKE2B 9e31cd945fea3830e472e97f774ae2ea36b6beebad6a474a876c770c56fe9f174e05de5fbc89d5dc4f821a9cbfbdda09b88f9ece223aef200410e968e0664adf SHA512 8e16b7a811e9e417d906406c8914c67c83af22c69dca5e7473042e2ef853a4d0a112fae0986f8066c7b32e170f3bf6c586588fd3fb507a5fff424112ec1af503
MISC metadata.xml 341 BLAKE2B e45d6753c4c9675cbb363078ea6614bcaccab98915bd3dcaaf7215c8ad608eba313c81f3bb90ce05e4b19981c408c44acfb09f1856652bd09bc459fa1c977d9e SHA512 572ab9227b892081aa5b43a60b4cdd50a4ab0953e7e820403836d7c1f61ac011df9506ef3bc036aa32fbdd8752f0693478d02d02a938558b2a46650aa2c1a0f3
diff --git a/dev-ruby/singleton/singleton-0.3.0.ebuild b/dev-ruby/singleton/singleton-0.3.0.ebuild
new file mode 100644
index 000000000000..a840f575de13
--- /dev/null
+++ b/dev-ruby/singleton/singleton-0.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="singleton.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The Singleton module implements the Singleton pattern"
+HOMEPAGE="https://github.com/ruby/singleton"
+SRC_URI="https://github.com/ruby/singleton/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}