summaryrefslogtreecommitdiff
path: root/dev-ruby/slim/slim-3.0.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-ruby/slim/slim-3.0.9.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/slim/slim-3.0.9.ebuild')
-rw-r--r--dev-ruby/slim/slim-3.0.9.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-ruby/slim/slim-3.0.9.ebuild b/dev-ruby/slim/slim-3.0.9.ebuild
deleted file mode 100644
index b3f7d2954da4..000000000000
--- a/dev-ruby/slim/slim-3.0.9.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_TASK_DOC="yard"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A template language aiming to reduce the syntax to the essential parts"
-HOMEPAGE="http://slim-lang.com/"
-LICENSE="MIT"
-
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 x86"
-SLOT="0"
-IUSE="doc"
-
-ruby_add_rdepend ">=dev-ruby/tilt-1.3.3:* <dev-ruby/tilt-2.1:*
- >=dev-ruby/temple-0.7.6:0.7"
-
-ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/redcarpet )"
-
-ruby_add_bdepend "test? ( dev-ruby/sass )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/I s:^:#:' Rakefile || die
-
- # This sinatra code expects tests to be installed but we strip those.
- sed -i -e "s/require 'sinatra'/require 'bogussinatra'/" Rakefile || die
-
- # Avoid tests for things we don't have. The builder test does not pass with tilt 2.x
- sed -i -e '/test_wip_render_with_asciidoc/,/^ end/ s:^:#:' \
- -e '/test_render_with_wiki/,/^ end/ s:^:#:' \
- -e '/test_render_with_creole/,/^ end/ s:^:#:' \
- -e '/test_render_with_builder/,/^ end/ s:^:#:' \
- -e '/test_render_with_org/,/^ end/ s:^:#:' test/core/test_embedded_engines.rb || die
-
- sed -i -e '/s\.files/ s/git ls-files/find . -type f -print/' \
- -e '/s\.executables/ s:git ls-files -- bin/\*:find bin -type f -print:' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_prepare() {
- sed -i -e '/Open3/ s:ruby:'${RUBY}':' test/core/test_commands.rb || die
-}