summaryrefslogtreecommitdiff
path: root/dev-ruby/sparklines/sparklines-0.5.2-r6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/sparklines/sparklines-0.5.2-r6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/sparklines/sparklines-0.5.2-r6.ebuild')
-rw-r--r--dev-ruby/sparklines/sparklines-0.5.2-r6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/sparklines/sparklines-0.5.2-r6.ebuild b/dev-ruby/sparklines/sparklines-0.5.2-r6.ebuild
new file mode 100644
index 000000000000..172146d38f26
--- /dev/null
+++ b/dev-ruby/sparklines/sparklines-0.5.2-r6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Create sparklines, small graphs to be used inline in texts"
+HOMEPAGE="http://sparklines.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-macos"
+IUSE=""
+
+RDEPEND="dev-ruby/rmagick"
+
+ruby_add_bdepend test "dev-ruby/tidy_table dev-ruby/dust"
+
+all_ruby_prepare() {
+ # Don't use deprecated rmagick require for compatibility with newer
+ # versions.
+ sed -i -e '/require/ s/RMagick/rmagick/' lib/sparklines.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -I. test/test_all.rb || die
+}