summaryrefslogtreecommitdiff
path: root/dev-ruby/stomp/stomp-1.4.10-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-02 05:16:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-02 05:16:35 +0100
commit6882d8d1110ef4feeec532196a1f0a25420d0fd1 (patch)
treec8a3d28a31e6c077d6b9097ff36b1232d2ce04b7 /dev-ruby/stomp/stomp-1.4.10-r1.ebuild
parent85a2a2153ef8027c2ba1be45143cd91914be0ad0 (diff)
gentoo auto-resync : 02:04:2023 - 05:16:35
Diffstat (limited to 'dev-ruby/stomp/stomp-1.4.10-r1.ebuild')
-rw-r--r--dev-ruby/stomp/stomp-1.4.10-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/stomp/stomp-1.4.10-r1.ebuild b/dev-ruby/stomp/stomp-1.4.10-r1.ebuild
new file mode 100644
index 000000000000..2344aac53557
--- /dev/null
+++ b/dev-ruby/stomp/stomp-1.4.10-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby bindings for the stomp messaging protocol"
+HOMEPAGE="https://github.com/stompgem/stomp"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.10-rspec-3.12.patch
+)
+
+all_ruby_prepare() {
+ # Skip specs that hang the test run indefinitely, most likely
+ # because of rspec-mocks deprecation output
+ rm -f spec/connection_spec.rb || die
+}