summaryrefslogtreecommitdiff
path: root/dev-ruby/strptime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-ruby/strptime
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-ruby/strptime')
-rw-r--r--dev-ruby/strptime/Manifest1
-rw-r--r--dev-ruby/strptime/strptime-0.2.5-r2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/strptime/Manifest b/dev-ruby/strptime/Manifest
index b2b1f01e3d99..b88455b84a04 100644
--- a/dev-ruby/strptime/Manifest
+++ b/dev-ruby/strptime/Manifest
@@ -1,3 +1,4 @@
DIST strptime-0.2.5.tar.gz 17431 BLAKE2B c9234ed0207e6bf214d4c011c883bc985cf527672f4bf9590617a742b4ea9a5cc0743388af23cc5f106350126eef16ffa89089d8715b0f8d371315412c7e5660 SHA512 6a85a3b45c43aa62a5c62e3902655351a839c4f2c397347356307c73ab160d053ea9dfc989f6d8687663bea5d8a60575f26b99b198b872bc1a3b2e0caa00a51f
EBUILD strptime-0.2.5-r1.ebuild 751 BLAKE2B 18647262390128094bf45b805fe2a24f7524f954e9e9ec2d465a5d4dc6a445917e9b13890d9f7ba4adf52a62eff1d76f7378fed5a260dd59954fe01b8578575f SHA512 f4a43e449a6ae838fe79cd42dbb35d68fff51768ec3da9953ad0e81a4e4708117baaadb49bc6cd52459a70a9893b794414eb6b3bbb06f71e1d08e258fc2e8102
+EBUILD strptime-0.2.5-r2.ebuild 753 BLAKE2B 8c5513400bd9f6b3d50c695b29343fd931756147e10face69580da2aa3ce0ae1cbc9b45e77bdcd9a862448b905d23bf75eacd2926bf3bba3337c920c44a848dc SHA512 8226f8585f0fd3c0ad4a2ee9cf0e54cc9042711caa96e5b983772a6d19306e0283b4bade21615f1fc0da961e6ff61fc0b4e48006760d1578d8ab19c86b62cdb5
MISC metadata.xml 248 BLAKE2B 0c876bde3c72e61d28284a95a837103e6d594c9f6fccbd6d7d1039f9c5a604347c20c334c9a57d80b152888fed536196f2807b477e8d0336c80affb0e28c9dc9 SHA512 b2b64178cf6cbbaa5fb4671ffe1ab88b83c920de363ae099ef74fa3e5eb8c8f0285c749cabc0cebf344951503d1b7309ae294afe9e7cf5172700182d8843fa14
diff --git a/dev-ruby/strptime/strptime-0.2.5-r2.ebuild b/dev-ruby/strptime/strptime-0.2.5-r2.ebuild
new file mode 100644
index 000000000000..bec5f0bd8e88
--- /dev/null
+++ b/dev-ruby/strptime/strptime-0.2.5-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="strptime.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/strptime/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/strptime
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A fast strptime/strftime engine which uses VM"
+HOMEPAGE="https://github.com/nurse/strptime"
+SRC_URI="https://github.com/nurse/strptime/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}