summaryrefslogtreecommitdiff
path: root/dev-ruby/subexec/subexec-0.2.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/subexec/subexec-0.2.3-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/subexec/subexec-0.2.3-r1.ebuild')
-rw-r--r--dev-ruby/subexec/subexec-0.2.3-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/subexec/subexec-0.2.3-r1.ebuild b/dev-ruby/subexec/subexec-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..0154b8bee659
--- /dev/null
+++ b/dev-ruby/subexec/subexec-0.2.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem eutils
+
+GITHUB_USER="nulayer"
+
+DESCRIPTION="Subexec spawns an external command with a timeout"
+HOMEPAGE="https://github.com/nulayer/subexec"
+SRC_URI="https://github.com/${GITHUB_USER}/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/shoulda )"
+
+all_ruby_prepare() {
+ rm Gemfile* || die
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+ sed -i -e '/begin/,/end/ s:^:#:' spec/spec_helper.rb || die
+}