summaryrefslogtreecommitdiff
path: root/dev-ruby/terminal-table/terminal-table-3.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /dev-ruby/terminal-table/terminal-table-3.0.1.ebuild
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'dev-ruby/terminal-table/terminal-table-3.0.1.ebuild')
-rw-r--r--dev-ruby/terminal-table/terminal-table-3.0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/terminal-table/terminal-table-3.0.1.ebuild b/dev-ruby/terminal-table/terminal-table-3.0.1.ebuild
new file mode 100644
index 000000000000..98afda9cb1c4
--- /dev/null
+++ b/dev-ruby/terminal-table/terminal-table-3.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.md Todo.rdoc"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple, feature rich ascii table generation library"
+HOMEPAGE="https://github.com/tj/terminal-table"
+SRC_URI="https://github.com/tj/terminal-table/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm64"
+SLOT="$(ver_cut 1)"
+IUSE="test"
+
+ruby_add_rdepend "|| ( dev-ruby/unicode-display_width:2 >=dev-ruby/unicode-display_width-1.1.1:1 )"
+
+ruby_add_bdepend "test? ( dev-ruby/term-ansicolor )"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}