summaryrefslogtreecommitdiff
path: root/dev-ruby/tidy_table
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /dev-ruby/tidy_table
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'dev-ruby/tidy_table')
-rw-r--r--dev-ruby/tidy_table/Manifest1
-rw-r--r--dev-ruby/tidy_table/tidy_table-0.0.5-r5.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/tidy_table/Manifest b/dev-ruby/tidy_table/Manifest
index ba1df27124ed..88b4989e0891 100644
--- a/dev-ruby/tidy_table/Manifest
+++ b/dev-ruby/tidy_table/Manifest
@@ -1,3 +1,4 @@
DIST tidy_table-0.0.5.gem 7168 BLAKE2B 7c00064c266bad9db6acf5066845cc6543c2d51fb5ac85240c9ac77d15004402588b992a0e56529123a1805e6c887ba23d135e801e07fcb918411d6706e7f596 SHA512 fbe9839587c3381ebabeb874b2460767491447b54501137f464c16bd251601670a6a260881792c117ee753e5b4d428f04295df041ffee56f109a1ff772346bcf
EBUILD tidy_table-0.0.5-r4.ebuild 611 BLAKE2B f8a35d290cf84d8cdc58ff6eeee44d55d22c4c40cce065b6ec44c5d840e660b9f74db281c63eadc91ec6af8647f6440e90c0feb6720b1e9ae0db49021ca10f92 SHA512 77a5ecd071b3e70384062d4b543e91f9064306a3114c317dd92678a31189ed55734447aa79b8b65a19efea00c27b2f7fa280176ae9ccb6fdc790c9a027a41cd9
+EBUILD tidy_table-0.0.5-r5.ebuild 751 BLAKE2B 231a004064e1312322e414451fb7a91e5e36a8e674d3299ca6003d9ee01006921ae4864fe5ed738c5b14aa3dd3a9662e95f032b4a8fbe2e2acda011278e2a4e0 SHA512 6faefbcd66012be5875f23663a726d329462a3d176fdf00cb9990104cece990bd62ce1c8b7e3f5a6aa657adfc9a8c6557ee16208b81d7d06c03cd6b0fc45ddf3
MISC metadata.xml 345 BLAKE2B 3ab7b55523f2742cb7c66ba65825395616176dbc68de46e5d95e8830f34c6add52ea5f24e1b97ca5022b823b7e49985ff1eb9997209e5bee191fd1e6725aec9d SHA512 9bcbcffb393ad0e2bfc74a05ea31149e656fa947a650932b51bcef54f32ff52b576c025d073361df9ff71a5c150496cbe5d98b74b8c614466b849cf95fe7aff9
diff --git a/dev-ruby/tidy_table/tidy_table-0.0.5-r5.ebuild b/dev-ruby/tidy_table/tidy_table-0.0.5-r5.ebuild
new file mode 100644
index 000000000000..b9cae1ccddc6
--- /dev/null
+++ b/dev-ruby/tidy_table/tidy_table-0.0.5-r5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tool to convert an array of struct into an HTML table"
+HOMEPAGE="https://github.com/topfunky/tidy_table"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Remove reference to RSpec 1
+ sed -i -e '/spec/d' -e '1irequire "date"' spec/spec_helper.rb || die
+
+ # Remove metadata so a stub gemspec will be created to avoid the
+ # wrong runtime dependency on dev-ruby/hoe.
+ rm -f ../metadata || die
+}