summaryrefslogtreecommitdiff
path: root/dev-ruby/tins/tins-1.26.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ruby/tins/tins-1.26.0.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ruby/tins/tins-1.26.0.ebuild')
-rw-r--r--dev-ruby/tins/tins-1.26.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/tins/tins-1.26.0.ebuild b/dev-ruby/tins/tins-1.26.0.ebuild
new file mode 100644
index 000000000000..6b8cb7458da3
--- /dev/null
+++ b/dev-ruby/tins/tins-1.26.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="All the stuff that isn't good enough for a real library"
+HOMEPAGE="https://github.com/flori/tins"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# Earlier versions of ruby bundled this dependency
+USE_RUBY="ruby26 ruby27" ruby_add_rdepend "dev-ruby/sync"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby24|*ruby25)
+ sed -i -e '/sync/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib tests/*_test.rb
+}