summaryrefslogtreecommitdiff
path: root/dev-ruby/tins/tins-1.31.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-ruby/tins/tins-1.31.0.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-ruby/tins/tins-1.31.0.ebuild')
-rw-r--r--dev-ruby/tins/tins-1.31.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/tins/tins-1.31.0.ebuild b/dev-ruby/tins/tins-1.31.0.ebuild
new file mode 100644
index 000000000000..fa0092a12ee4
--- /dev/null
+++ b/dev-ruby/tins/tins-1.31.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="All the stuff that isn't good enough for a real library"
+HOMEPAGE="https://github.com/flori/tins"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/sync"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby25)
+ sed -i -e '/sync/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib tests/*_test.rb
+}