summaryrefslogtreecommitdiff
path: root/dev-ruby/tins/tins-1.32.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-18 12:58:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-18 12:58:33 +0000
commit0374a8491c853f9331b95ed2a38e688e4d2edce5 (patch)
tree563dd0e0f6ee34895358db0f88d683934ca21756 /dev-ruby/tins/tins-1.32.0.ebuild
parent070c77515d1406e762e9e344856546f0a15765b6 (diff)
gentoo auto-resync : 18:11:2022 - 12:58:32
Diffstat (limited to 'dev-ruby/tins/tins-1.32.0.ebuild')
-rw-r--r--dev-ruby/tins/tins-1.32.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/tins/tins-1.32.0.ebuild b/dev-ruby/tins/tins-1.32.0.ebuild
new file mode 100644
index 000000000000..26d7632e10d8
--- /dev/null
+++ b/dev-ruby/tins/tins-1.32.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="All the stuff that isn't good enough for a real library"
+HOMEPAGE="https://github.com/flori/tins"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/sync"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib tests/*_test.rb
+}