summaryrefslogtreecommitdiff
path: root/dev-ruby/typhoeus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-03 08:59:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-03 08:59:05 +0000
commite6ba529df30e3fc9dfdf55ec5797f2f764df6e54 (patch)
tree6b38c918c796f792ef4b18b57437c05a1fd46ae8 /dev-ruby/typhoeus
parentfbe7acf59ebf6dc3f04a6ef108ff3887fa5d7972 (diff)
gentoo auto-resync : 03:12:2022 - 08:59:05
Diffstat (limited to 'dev-ruby/typhoeus')
-rw-r--r--dev-ruby/typhoeus/Manifest1
-rw-r--r--dev-ruby/typhoeus/typhoeus-1.4.0-r1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/typhoeus/Manifest b/dev-ruby/typhoeus/Manifest
index 3639a2f16fe3..8abda0644c0b 100644
--- a/dev-ruby/typhoeus/Manifest
+++ b/dev-ruby/typhoeus/Manifest
@@ -1,3 +1,4 @@
DIST typhoeus-1.4.0.gem 56832 BLAKE2B 1f188a2c174a9d0e2cc0afc10f96d98a8c78278c1fa53eeb88da6f4f3986c8e204171a9bb817c95a217360346bda319711e7c89095ad48e878cbc3efc21e9887 SHA512 f48a99fd554f4d06d37a0a804ee79dd8423d9bff765394537ab0edba615e132d25660a6eb455e8628f59bd56c7ea26f4a195827d5287a53e58e3aeb394477284
+EBUILD typhoeus-1.4.0-r1.ebuild 979 BLAKE2B 6765e8a956d27f75a0df6898192a5a2fefb1fdac08bb18055eb062afaf4586012e3242b77efdccb64474d81a48c4839eafdab957cfe72ab4550ac29ece4cd311 SHA512 7a0d81b86b9920648b0439f6d80bfd548bc71a9fd3138d7cf766ae461713644b755acaa74ab966f82cdd503aa9b3087b8d6c2ef6fce682e20bd42457f27cecd0
EBUILD typhoeus-1.4.0.ebuild 785 BLAKE2B 06daf3edc28829c0632dc1c7d484f1b3e392d0fde48d3a710e436f05700ca4c044a5e2216bba38fe1d902cf82e7e2d6a0b1451c8830895ec57ddc6171acb94f8 SHA512 3db6ee3d082abb2a452a7f311786f9f237c92460f0322c859c51552d85bc8606c7bb37d2ff04c96f5fda7d2afe50f11267b3eb1edd2ab01223aa785483c7dc98
MISC metadata.xml 384 BLAKE2B f9b2404ac92e77233601283e52811ee504d139320b17232b7ea47a43d34cfde7234f4168607c7410f87c19d738a1af7a1447a03b042c62334d0bad2908d806c6 SHA512 3a27d3081fb9b59170213edd8fe3af51fd204fca382c72b074fdbfe7b94ba3ca5d08bca123ed4acefe0f8b6763fdeeb89ef505350ca238f8a8f19b20eab0b71c
diff --git a/dev-ruby/typhoeus/typhoeus-1.4.0-r1.ebuild b/dev-ruby/typhoeus/typhoeus-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..6dc99f1ce694
--- /dev/null
+++ b/dev-ruby/typhoeus/typhoeus-1.4.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md UPGRADE.md"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Runs HTTP requests in parallel while cleanly encapsulating handling logic"
+HOMEPAGE="https://rubygems.org/gems/typhoeus/
+ https://github.com/typhoeus/typhoeus"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/ethon-0.9.0"
+
+ruby_add_bdepend "test? ( dev-ruby/json || ( dev-ruby/faraday:1 >=dev-ruby/faraday-0.9 ) >=dev-ruby/sinatra-1.3 >=dev-ruby/redis-3.0 >=dev-ruby/dalli-2.7.9 )"
+
+all_ruby_prepare() {
+ sed -e '/bundler/I s:^:#:' -i Rakefile spec/spec_helper.rb || die
+ sed -i -e '3igem "faraday", "<2"; require "timeout"' spec/spec_helper.rb || die
+ sed -i -e '/Rack::Handler::WEBrick/ s/options/\*\*options/' spec/support/localhost_server.rb || die
+}