summaryrefslogtreecommitdiff
path: root/dev-ruby/websocket/websocket-1.2.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-20 11:11:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-20 11:11:53 +0100
commit2ce67506e52bee4f16032b08b1be9cee9e84e10d (patch)
treee1d7d7604754a8c356d3e93ed7fabb5221cb3976 /dev-ruby/websocket/websocket-1.2.10.ebuild
parent0bb372e16b84da4809f561d11ffaa30e983ab26d (diff)
gentoo auto-resync : 20:09:2023 - 11:11:53
Diffstat (limited to 'dev-ruby/websocket/websocket-1.2.10.ebuild')
-rw-r--r--dev-ruby/websocket/websocket-1.2.10.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/websocket/websocket-1.2.10.ebuild b/dev-ruby/websocket/websocket-1.2.10.ebuild
new file mode 100644
index 000000000000..e1f235d0ecb9
--- /dev/null
+++ b/dev-ruby/websocket/websocket-1.2.10.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Universal Ruby library to handle WebSocket protocol"
+HOMEPAGE="https://github.com/imanel/websocket-ruby"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rspec-its
+ dev-ruby/webrick
+ )
+"