summaryrefslogtreecommitdiff
path: root/dev-ruby/wirble/wirble-0.1.3-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/wirble/wirble-0.1.3-r4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/wirble/wirble-0.1.3-r4.ebuild')
-rw-r--r--dev-ruby/wirble/wirble-0.1.3-r4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/wirble/wirble-0.1.3-r4.ebuild b/dev-ruby/wirble/wirble-0.1.3-r4.ebuild
new file mode 100644
index 000000000000..6c641ae6d4f4
--- /dev/null
+++ b/dev-ruby/wirble/wirble-0.1.3-r4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README ChangeLog"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wirble is a set of enhancements for Irb"
+HOMEPAGE="http://pablotron.org/software/wirble/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+pkg_postinst() {
+ elog "The quick way to use wirble is to make your ~/.irbrc look like this:"
+ elog " # load libraries"
+ elog " require 'rubygems'"
+ elog " require 'wirble'"
+ elog " "
+ elog " # start wirble (with color)"
+ elog " Wirble.init"
+ elog " Wirble.colorize"
+}