summaryrefslogtreecommitdiff
path: root/dev-ruby/wisper/wisper-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-26 00:07:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-26 00:07:28 +0100
commit994fe442814c4d169bb0f1ee9745604928006b39 (patch)
tree630f10f7414f44018095dd9d3cf9df55852a9d41 /dev-ruby/wisper/wisper-3.0.0.ebuild
parentf8999218b5a6eafa151e7367030cbfdb69e045ed (diff)
gentoo auto-resync : 26:05:2024 - 00:07:27
Diffstat (limited to 'dev-ruby/wisper/wisper-3.0.0.ebuild')
-rw-r--r--dev-ruby/wisper/wisper-3.0.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/wisper/wisper-3.0.0.ebuild b/dev-ruby/wisper/wisper-3.0.0.ebuild
new file mode 100644
index 000000000000..62ac8565e3a8
--- /dev/null
+++ b/dev-ruby/wisper/wisper-3.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A micro library providing objects with Publish-Subscribe capabilities"
+HOMEPAGE="https://github.com/krisleech/wisper"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+all_ruby_prepare() {
+ sed -i -e '/coverall/I s:^:#:' spec/spec_helper.rb || die
+}