summaryrefslogtreecommitdiff
path: root/dev-ruby/xml-simple/xml-simple-1.1.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/xml-simple/xml-simple-1.1.9.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/xml-simple/xml-simple-1.1.9.ebuild')
-rw-r--r--dev-ruby/xml-simple/xml-simple-1.1.9.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/xml-simple/xml-simple-1.1.9.ebuild b/dev-ruby/xml-simple/xml-simple-1.1.9.ebuild
new file mode 100644
index 000000000000..705a80683e40
--- /dev/null
+++ b/dev-ruby/xml-simple/xml-simple-1.1.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+COMMIT=7b8bdf7b33ab872bb4d1fb8eeecba5c5e1a4a421
+
+RUBY_FAKEGEM_GEMSPEC="xml-simple.gemspec"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/maik/xml-simple/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Easy API to maintain XML. A Ruby port of Grant McLean's Perl module XML::Simple"
+HOMEPAGE="https://github.com/maik/xml-simple"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+IUSE=""
+
+RUBY_S="${PN}-${COMMIT}"
+
+ruby_add_rdepend "dev-ruby/rexml"
+
+each_ruby_test() {
+ cd test || die
+ for i in *.rb; do
+ ${RUBY} -I../lib ${i} || die
+ done
+}