summaryrefslogtreecommitdiff
path: root/dev-ruby/yard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-05 12:28:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-05 12:28:41 +0100
commit5d93bae2c1576ab817f482024a6d47592829407b (patch)
tree1fd9619473e6cdba4c004554cb1743ec16654102 /dev-ruby/yard
parent518b45bffd19d0b75715f338985f96c459f9d129 (diff)
gentoo auto-resync : 05:09:2024 - 12:28:40
Diffstat (limited to 'dev-ruby/yard')
-rw-r--r--dev-ruby/yard/Manifest2
-rw-r--r--dev-ruby/yard/yard-0.9.37.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-ruby/yard/Manifest b/dev-ruby/yard/Manifest
index 6202371d5f6b..9223c7f803c7 100644
--- a/dev-ruby/yard/Manifest
+++ b/dev-ruby/yard/Manifest
@@ -1,4 +1,6 @@
AUX yard-0.9.34-beginless-range.patch 1588 BLAKE2B 08b63f291f017c63db9f1b7c88107075c9b928dabc650bae7710794ae81e14a39fd9307111d408a7450b8598697220cc07e47005fb3c2713cc433bfa14a82ae0 SHA512 f71491b057ec9f903ad67002489e2009cfbed8ddfe210f7305bdbb22900695c0c0fd58802335fb03f7523d8583043b3649603617ddcaf37241270f28b4427122
DIST yard-0.9.36-git.tgz 938567 BLAKE2B 8672b94149b4bbecd3fb80c1d386e3cdfd4013ad88969958269abd480426e41990067df0e5352df1a983a1572129b91a31129a71eae872cc00712e6e992a07c5 SHA512 09639d7ac6fed28906b40e08c16e305f44416206f67947fbdedf4adbb0be92d1e15ade9a04509f2847063b39baaa7a5bcbd585031808baaaf5acf14f06b471d5
+DIST yard-0.9.37-git.tgz 941020 BLAKE2B 40c9ad5be234d00d84fd3187271357691841a2b57fd37ee9fc346e8d8c91c54f751d6ad46df988f6d40e3a1c3c4d644cfdce825579e7294b23ec52f28489e45d SHA512 f48a25df1fba7cdde7388842c6bce63ab149e613921cca8c809adb2a3bd7edce49c573c8867e62a3cb33c8cb3868dd67bd87f34c65ffce1e66c1353a2f93f9ca
EBUILD yard-0.9.36.ebuild 2651 BLAKE2B 97f97005b142d06bcfe713a320c29c8809e557a8b3c1f0138d69324585ed154a72a201e2cb3ec07e9bf643986a41d1aee4e6e93c6cf0db55451ad98a528feb3c SHA512 ea6159292e942d74e2f578777ba52b6c67c03c9253ed68204420944a2f56d05851850eb193e675bcfce109fcf71ed79c617d23c5062ba282b3de601711eceb68
+EBUILD yard-0.9.37.ebuild 2658 BLAKE2B 6083c2e317c216a060832d60272bb0452058888d752e3ce6d07261cd3bc0bab63f4346fa38a8d5bf4712118d5bb62f9b06d5d2b72b45c72d927cbb5cb68c9d78 SHA512 8a33788dc49a1485b2278fc25bf5c0f3454da6a3d40459695f849c11ba231d1db73e58dd652af993b5f7ba9dcba0d8a107ed850d72f1cba943f807d8bee6575c
MISC metadata.xml 338 BLAKE2B 17efe658faab09d5935ba472a803a1267f7606a44b157f29bcdecc8cea8af90902ae47012fdd4426357a8ceba5526ca24d737be8fe161c34e28e5362ccc94f16 SHA512 d1f45e2202c86b247b1b872ada72fef392d20260bc3ccc78164c26614dc80b8fe05518356248e3e7f15e2c70b29a9c0909bc738267261eb808965bcb0ed4ebc9
diff --git a/dev-ruby/yard/yard-0.9.37.ebuild b/dev-ruby/yard/yard-0.9.37.ebuild
new file mode 100644
index 000000000000..5d1f8575ffe4
--- /dev/null
+++ b/dev-ruby/yard/yard-0.9.37.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_DOCDIR="doc docs"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates .yardopts"
+
+RUBY_FAKEGEM_GEMSPEC="yard.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="https://yardoc.org/"
+
+# The gem lacks the gemspec file needed to pass tests.
+SRC_URI="https://github.com/lsegal/yard/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.34-beginless-range.patch"
+)
+
+ruby_add_bdepend "doc? ( || ( dev-ruby/maruku dev-ruby/rdiscount dev-ruby/kramdown ) )"
+
+ruby_add_bdepend "test? ( dev-ruby/rack:2.2 >=dev-ruby/rspec-3.11.0 dev-ruby/webrick )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '3igem "rack", "~> 2.2.0"' spec/spec_helper.rb || die
+
+ sed -i -e '/samus/I s:^:#:' Rakefile || die
+
+ sed -i -e 's/git ls-files/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid specs that make assumptions on load ordering that are not
+ # true for us. This may be related to how we install in Gentoo. This
+ # also drops a test requirement on dev-ruby/rack.
+ rm -f spec/cli/server_spec.rb || die
+
+ # Avoid specs that only work with bundler
+ sed -i -e '/#initialize/,/^ end/ s:^:#:' spec/cli/yri_spec.rb || die
+ sed -e '/overwrites options with data in/askip "wrong assumptions on file access"' \
+ -e '/loads any gem plugins starting with/askip "wrong assumptions on file access"' \
+ -i spec/config_spec.rb || die
+
+ # Avoid specs making assumptions about how rubygems works internally
+ sed -i -e '/searches for .gem file/askip "rubygems internals"' spec/cli/diff_spec.rb || die
+
+ # Fix broken spec
+ sed -i -e '/:exist?/aallow(File).to receive(:exist?).and_call_original' spec/i18n/locale_spec.rb || die
+
+ # Avoid ruby31 failure on whitespace-only differences
+ sed -i -e '/shows a list of nodes/askip "Whitespace differences on ruby31"' spec/parser/ruby/ast_node_spec.rb || die
+
+ # Avoid redcarpet-specific spec that is not optional
+ sed -i -e '/autolinks URLs/askip "make redcarpet optional"' spec/templates/helpers/html_helper_spec.rb || die
+
+ # Avoid asciidoc-specific spec that is not optional
+ sed -e '/\(AsciiDoc specific\|AsciiDoc header\)/askip "skipping asciidoc test"' \
+ -i spec/templates/helpers/html_helper_spec.rb || die
+}