summaryrefslogtreecommitdiff
path: root/dev-scheme/c-wrapper/c-wrapper-0.6.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-scheme/c-wrapper/c-wrapper-0.6.1-r2.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-scheme/c-wrapper/c-wrapper-0.6.1-r2.ebuild')
-rw-r--r--dev-scheme/c-wrapper/c-wrapper-0.6.1-r2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-scheme/c-wrapper/c-wrapper-0.6.1-r2.ebuild b/dev-scheme/c-wrapper/c-wrapper-0.6.1-r2.ebuild
new file mode 100644
index 000000000000..3f8277774536
--- /dev/null
+++ b/dev-scheme/c-wrapper/c-wrapper-0.6.1-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+DESCRIPTION="Foreign function interface for C and Objective-C libraries"
+HOMEPAGE="http://www.koguro.net/prog/c-wrapper/"
+SRC_URI="http://www.koguro.net/prog/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 x86"
+IUSE="examples"
+
+RDEPEND="dev-scheme/gauche:=
+ dev-libs/libffi:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-closure.patch
+ "${FILESDIR}"/${PN}-gcc-5.patch
+ "${FILESDIR}"/${PN}-gentoo.patch
+ "${FILESDIR}"/${PN}-glibc-2.25.patch
+ "${FILESDIR}"/${PN}-info.patch
+ "${FILESDIR}"/${PN}-texinfo-6.7.patch
+ "${FILESDIR}"/${PN}-clang.patch
+ "${FILESDIR}"/${PN}-float128.patch
+ "${FILESDIR}"/${PN}-local-typedef.patch
+ "${FILESDIR}"/${PN}-extend-parser.patch
+)
+HTML_DOCS=( doc/${PN}-ref{e,j}.html )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_test() {
+ emake -j1 -s check
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+}