summaryrefslogtreecommitdiff
path: root/dev-scheme/elk/elk-3.99.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-scheme/elk/elk-3.99.8.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-scheme/elk/elk-3.99.8.ebuild')
-rw-r--r--dev-scheme/elk/elk-3.99.8.ebuild23
1 files changed, 16 insertions, 7 deletions
diff --git a/dev-scheme/elk/elk-3.99.8.ebuild b/dev-scheme/elk/elk-3.99.8.ebuild
index cf741d71b8c2..a9e62f4c49fe 100644
--- a/dev-scheme/elk/elk-3.99.8.ebuild
+++ b/dev-scheme/elk/elk-3.99.8.ebuild
@@ -1,22 +1,23 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
DESCRIPTION="Scheme implementation designed to be embeddable extension to C/C++ applications"
HOMEPAGE="http://sam.zoy.org/elk"
SRC_URI="http://sam.zoy.org/elk/${P}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
-DEPEND=""
+src_configure() {
+ econf --disable-static
+}
src_compile() {
# parallel build is broken
- emake -j1 || die "Make failed!"
+ emake -j1
}
# tests are run automatically during make and fail with default src_test
@@ -26,5 +27,13 @@ src_test() {
src_install() {
# parallel install is broken
- emake -j1 DESTDIR="${D}" install || die "Install failed"
+ emake -j1 DESTDIR="${D}" \
+ docsdir="${EPREFIX}"/usr/share/doc/${PF} \
+ examplesdir="${EPREFIX}"/usr/share/doc/${PF}/examples \
+ install
+ einstalldocs
+ docompress -x /usr/share/doc/${PF}
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}